Wayland is missing

Hello, I installed EndeavourOS last week and I was wondering why my installation came preinstalled with X11 and some user’s came with Wayland. I would like to try Wayland on my computer but I don’t know how to enable it. Can anyone help me?

Let me attach some pictures of my PC specs, OS version and login screen in case it might be useful.


It should be the icon or gear at the bottom right of the screen to change from x11. Are you sure your resolution isn’t set too large and it’s actually off the screen?

Edit: When you click in the box to enter your password you should see the gear icon omn the bottom right before logging in.

Edit: Check with

echo $XDG_SESSION_TYPE

Maybe you need to enable early KMS as described here.

that command returns X11. I don’t think the screen resolution is the issue as the rest of the UI seems to behave just fine.

I haven’t tried that… I will give it a shot tomorrow and see if it works. Thanks!!

Nvidia maybe problem …

1 Like

It’s on the upper right in their screen shot.

exactly that on Nvidia drivers it will default to X11 – it needs some settings changed to get wayland working on Nvidia drivers.

1 Like

Well if in fact it’s on Nvidia then that explains a lot.

1 Like

Nvm

it is not. That is the accessibility menu

Is it Nvidia graphics?

inxi -Faz --no-host | eos-sendlog

It looks like you have NVIDIA GPU, i believe the installer auto installs x11 when you use the NVIDIA install since NVIDIA and Wayland do not play well.

1 Like

Yes it is https://clbin.com/9nasA

WaylandEnable=true

I just tried that by following the instructions on the wiki, it didn’t work.
I also tried adding a kernel parameter nvidia-drm.modeset=1 but it didnt work either.
any ideas??

Yesterday I managed to solve this issue. What I did was follow this guide here: https://forum.manjaro.org/t/howto-use-wayland-with-propietary-nvidia-drivers/36130

But I changed a few steps based on info I read on the wiki:

  • For step 2, I recommend running: cp /usr/lib/udev/rules.d/61-gdm.rules /etc/udev/rules.d/61-gdm.rules as the folder in the /etc directory takes preference and won’t be replaced on a system update.
  • For step 4, I recommend following this guide to build the grub proplerly: https://wiki.archlinux.org/title/kernel_parameters#GRUB
3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.