Watchdog didn't stop at shutdown

I get a couple of lines at the end of the shutdown “messages” regarding watchdog not being stopped. Is it still running in the system despite nowatchdog kernel boot parameter?

BOOT_IMAGE=/boot/vmlinuz-linux-zen root=UUID=9b5d5d2c-3759-4527-a1fd-e4e9848e1ddf rw resume=UUID=e1073bcb-719a-4359-bcde-1d74cd6bd21e loglevel=3 nowatchdog

$ cat /proc/sys/kernel/watchdog
0
$ lsmod | grep iTCO_wdt

iTCO_vendor_support    16384  1 iTCO_wdt
iTCO_wdt               16384  0

Does this mean that the module still gets loaded? Perhaps I should prevent iTCO_vendor_support from loading as well at boot.

:eye: https://wiki.archlinux.org/index.php/Improving_performance#Watchdogs

i have this

lsmod | grep iTCO_wdt
iTCO_wdt               16384  0
intel_pmc_bxt          16384  1 iTCO_wdt
iTCO_vendor_support    16384  1 iTCO_wdt
1 Like

Do you get the watchdog didn’t stopp message as well at shutdown?

no error from watchdog , or very few in the past

I do get this errors . But not all the time . Didn’t bother about these yet

OK
:+1:t4:

Same here. Watschdog errors at shutdown.

1 Like

I will try to block iTCO_vendor_support as well to see if the messages will go away. I’ll be back with the result a bit later on.

1 Like

Blocking iTCO_vendor_support (and iTCO_wdt just in case) in a .conf file in /etc/modprobe.d seems to have taken care of those messages.

:eye: https://wiki.archlinux.org/index.php/Blacklisting#Blacklisting

2 Likes

I solved this adding module_blacklist=iTCO_wdt,iTCO_vendor_support to my kernel parameters.

2 Likes

Also to the kernel parameters nowatchdog

2 Likes

Yup, I forgot to mention this, but it is also in my parameters.

How can I add this?

I guess nowatchdog is already added to the kernel boot parameters by default. Check:

cat /proc/cmdline

1 Like
BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=c884383f-7e51-4984-9883-cb661682c5e6 rw quiet loglevel=3 nowatchdog

Yep, enabled by default with EndeavourOS - which is a nice little tweak.

3 Likes

So THAT can’t be the mistake … :unamused:

2 Likes

Check what watchdog modules your system is using:

lsmod | grep -e dog -e wdt

and blacklist them.

2 Likes
[uwe@HAL ~]$ lsmod | grep -e dog -e wdt
iTCO_wdt               16384  0
intel_pmc_bxt          16384  1 iTCO_wdt
iTCO_vendor_support    16384  1 iTCO_wdt
[uwe@HAL ~]$ 

How and WHERE can I blacklist them? I never had such a problem before!

See above:

3 Likes