[Warning] Possible crash with xorg-server 1.20.12-1 and lightdm

Hello.

It seems to be there is a bug with xorg-server 1.20.12-1 which leads to a crash when trying to login into your Window Manager / Desktop Environment using lightdm. GDM works fine for me :slight_smile:

See this archlinux bug report: https://bugs.archlinux.org/task/71483
And this bug report on Xorg tracker: https://gitlab.freedesktop.org/xorg/xserver/-/issues/1195

Looks like another thread was written: Xorg server update could brake logins to WM/DE with lightdm

Workaround:

  1. Use ctrl-alt-F2 keyboard shortcut
  2. Log in using your user name
  3. sudo downgrade xorg-server and select 1.20.11-1 package.
  4. Log out and use ctrl+alt-F7 keyboard shortcut or reboot.
5 Likes

its combination … idk how or what…

lxqt in vm with xfwm4 get return openbox seems ok. lxqt with metacity seems also ok…

1 Like

lightdm with i3 works fine for me (intel gpu driver)

1 Like

Lightdm+xfce+autologin works fine here.

1 Like

i use xmonad and aweesomewm with Lightdm
and it works fine here

1 Like

BTW, I use SDDM. No issues.

3 Likes

i do not have any issue here too, lightdm + xfce4 nouveau, i3 nvidia, i3 intel, vms also running fine.

1 Like

Looks like it is related to the use of both modesettings and glamor (which is long dead) → https://www.freedesktop.org/wiki/Software/Glamor/

It took me nearly an hour, but I nailed the regression window.

Here is my comment and the commits (last working one and first broken one):

Last working commit: 4e11bd39 - modesetting: Disable reverse prime offload mode for displays running on evdi,udl
First broken commit: 464cbee1 - modesetting: Initialize present extension despite glamor is disabled

So, if you do not use glamor, you’re safe from this bug.

3 Likes

No issues here with lightdm on Xfce with Btfs on Luks and snaps shots with tmeshift running Nvidia also.

1 Like

All is well with lightdm and Cinnamon on various machines with intel, nvidia, and nvidia-390xx.

Isn’t this the very thing several of us have experienced for months? About 1 in 6 boots for me result in black screen and the only way to get out of it is CTRL+ALT+F2.

As I said I have reported on this issue before, I run lightdm with XFCE and it has been this way since I returned from using Fedora in May.

On your set up with lightdm did you enable logind-check-graphical=true inside lightdm.conf?

…No? I think the only two rows in the entire conf file that aren’t commented out are

run-directory=/run/lightdm
greeter-session=lightdm-gtk-greeter

Remember, I installed Xfce with lightdm via the ISO, so this is the default Endeavour settings.
Edit: also, the default value seems to be “true” anyway since the commented line is:

#logind-check-graphical=false

which to me indicates that unless you uncomment that, the default value is “=true”

I’m not sure but as far as i know it was said in the wiki to un-comment it and change to true. That’s how i have mine set and i have no issues. I also know i recommended this to others who had issues? :thinking:

2 Likes

Hi,
I’ve the same/similar problem, that I cannot login after an upgrade yesterday evening.
My System is an up to date Endeavour linux using XFCE an LXDM (as window manager), as a qemu-kvm VM (host: debian 10)

After a “pacman -Syu” and a reboot and entering the password at the login window, the screen is cleared and after a second or two, the login screen shows up again. No Desktop. Repeatedly.

When I “ignore” the “xorg-server” and the “xorg-server-common” for their new versions 1.20.12-1, then I can login without a problem. (pacman -Syu --ignore=xorg-server,xorg-server-common)

I don’t think, it has to do with the window-manager, as others (like lightdm), reported above, do work.

Maybe someone has a solution or a workaround. / Hilmar.

(Btw.: Same problem with two archman VM’s (Arch Linux based (XFCE))

I’m not sure this is the same issue as i was referring to because @Beardedgeek72 was talking about having this for months so i asked about the login check for graphics which was another issue from quite a bit earlier.

1 Like

This “no login possible” problem is new for me it start with xorg-server 1.20.12-1, *11-1 works perfectly. No black screen - I also remember this black screen thing months ago. And the title of this thread explicitly refers die the *.12-1 version of xorg-server.

I’ve made a few more tests and switched the the WM from lxdm to lightdm (with xorg-server *11-1) and changed the login to “autologin”, which worked as expected after reboot.

Then I upgraded xorg-server and xorg-server-common to version 1.20.12-1. After reboot the lightdm login screen appeared, although the autologin settings in lightdm.conf and group(autologin) where unchanged! The again appeared lightdm login showed the same problem as before (no login possible).

Something with xorg-server *.12-1 causes a (new/different?) display of the login window, not adhering my autologin setup.

Because i have the same problem with lxdm, the problem seems to be more on the xorg-server side, I think.
So I still have to --ignore the Xserver upgrade.
Any thoughts/solutions?

Regards. / Hilmar.

I’ve found this thread in the Manjaro forum:
https://forum.manjaro.org/t/lightdm-resetting-when-used-with-bspwm-after-updating/46764
Reading the 1st sentence in the fist entry to this thread, the symptoms of the problem are the same/very similar. In the last entry, the user suspects a .Xauthority file with wrong content as the cause and he proposes these 4 steps, when at the login window and after upgrading to *.12-1:

0. stop lightdm service
1. remove the .Xauthority file
2. start any DE with startx / xinit and stop it
4. start lightdm service

I performed those steps, but, at least with me, the problem remains.

In this thread:

there is a link to:
https://gitlab.freedesktop.org/xorg/xserver/-/issues/1195
They suspect, that an NVIDIA GPU and the corresponding driver might cause the problem (iicc), and no solution up to now.
But in my case, the Endeavour VM uses the “Intel HD Graphics 530” HW of the KVM-host transparently with the “Red Hat QXL paravirtual Graphics Card” driver. No NVIDIA GPU.

The solution is always the workaround to downgrade the xserver to *.11-1, which is unsatisfying.

Regards. / Hilmar.

Please don’t try random commands you find on the net. The difference between manjaro and arch is like crossing the Golden Gate Bridge. The difference between EndeavourOS and arch is like walking down you driveway to get the mail.

1 Like

Just to mention, that the latest iso (endeavouros-2021.04.17-x86_64.iso) should not be used for new installation together with XFCE and the “online” (sic!) mode, because it installs this xserver version *.12-1.

I’ve done this. And this realy strange: After the very first reboot, when the new system comes up, I could login (lightdm-greeter) without a problem. But after the 2nd reboot, the reported problem was there again, no login possible. Then I tried all other login-managers provided by the ‘welcome’ app (gdm, lxdm, sddm) together with XFCE. They all showed the same behaviour: 1. Login: ok, further logins: no.

Then installed endeavour using gnome/gdm desktop. The problem didn’t show up at all (neither at 1st login nor 2nd+).

Regards. / Hilmar.

1 Like