War Thunder crashes due to running out of memory, was fine on Manjaro

Hello all, yesterday I made the switch to EndeavourOS from Manjaro. I managed to set up everything, however I am encountering one issue.

I played War Thunder regularly, and without issues for the most part, on Manjaro. On low graphics I could manage around 60 fps, depending on what’s on the screen ofc. I installed the game through Steam (same as before), but when I start it up i get a fatal error “vulkan: Out of memory. Try lowering graphics settings and/or closing other memory consuming applications”.
I tried lowering to minimal graphics but encounter the same issue. My other games I play (Don’t Starve and DST) are less taxing in the graphics department and run fine.

I didn’t change the hardware, only the OS. Does anyone know what could be the cause?

Inxi: http://ix.io/4CQC

If I remember correctly, I think Manjaro uses some custom kernel similar to Zen. Try installing the Zen kernel (sudo pacman -S linux-zen linux-zen-headers) and boot with it to see if anything changes. Maybe it will work.

It’s a long shot, but I don’t play these games or use Manjaro, so I have no other ideas, perhaps someone has something else to share.

1 Like

Make sure you met requirements and have all relevant vulkan packages installed.
It’s likely you miss vulkan packages.

I doubt it’s connected to kernel at all, besides usually zen is less stable than normal or lts one…

Another user experienced the same issue with similar circumstances (WT crashed after switching to Arch).

The response from the developer:

Hello, this is a known issue that currently WT has issues with hitting the VRAM limit and crashing, Do you have a option in your UEFI/BIOS to change the amount of RAM that is allocated to the iGPU? “Shared memory” or something like that. If so you could see if it is possible to increase that or set it to “Auto”. That might help.



Thank you very much! It worked.

You’re welcome.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.