Wait until kernel time synchronized

I keep getting this halt during boot with the message: Wait until kernel time synchronized
this can take between 30sec to 2 mins.
Fresh install same issue
DE: Gnome
Kernel is 5.5
Bios time is synced
My machine is a X1-Carbon gen 6 with I7 CPU and Intel 620HD graphics.

Any ideas?

hello,which iso you used

On the EOS Welcome screen is “Detect system issues” click that and it will fix (disable) the time sync.

Used the netinstaller

Tried that, it removed some nvidia files but did nothing for the time sync

Hmm that is supposed to fix it…??? try this without the quotes.

“systemctl disable systemd-time-wait-sync && systemctl stop systemd-time-wait-sync”

There were a lot of people who were getting issues with Linux 5.5. You may need to install the LTS kernel for the time being and use that as your default kernel until these issues are resolved.

Changed to the LTS kernel, but for some reason the issue remains

1 Like

you can make us screenshots, more inxi -F to have all the info thank you

What screen shots you want?

here is the result of inxi

System:
Host: X1-JOHBR Kernel: 4.19.101-1-lts x86_64 bits: 64
Desktop: Gnome 3.34.3 Distro: EndeavourOS
Machine:
Type: Laptop System: LENOVO product: 20KH006KMX v: ThinkPad X1 Carbon 6th
serial:
Mobo: LENOVO model: 20KH006KMX v: SDK0J40697 WIN serial:
UEFI: LENOVO v: N23ET69W (1.44 ) date: 11/25/2019
Battery:
ID-1: BAT0 charge: 44.5 Wh condition: 56.9/57.0 Wh (100%)
CPU:
Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP
L2 cache: 8192 KiB
Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800
3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Graphics:
Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Display: x11 server: X.Org 1.20.7 driver: i915 resolution: 2560x1440~60Hz
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k4.19.101-1-lts
Network:
Device-1: Intel Ethernet I219-V driver: e1000e
IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
IF: wlan0 state: down
Drives:
Local Storage: total: 238.47 GiB used: 7.50 GiB (3.1%)
ID-1: /dev/nvme0n1 vendor: LITE-ON model: CA3-8D256 size: 238.47 GiB
Partition:
ID-1: / size: 233.43 GiB used: 7.50 GiB (3.2%) fs: ext4 dev: /dev/dm-0
Sensors:
System Temperatures: cpu: 49.5 C mobo: N/A
Fan Speeds (RPM): cpu: 0
Info:
Processes: 255 Uptime: 9m Memory: 15.43 GiB used: 1.31 GiB (8.5%)
Shell: bash inxi: 3.0.37

Hello @Keruberne
Start the computer and wait till it loads to the desktop. Try running update mirrors on the welcome app first and save. Then run detect system issue.

1 Like

Hi
Sorry made no difference.

@Keruberne
Well it was worth a try. What is the output of

timedatectl status

Edit: Could you also post the output of this

timedatectl timesync-status

you can show us the error message thank you

1 Like

@Keruberne
Could we also see if the service is actually running?

systemctl status systemd-networkd systemd-timedated systemd-timesyncd

Here are the results
timedatectl status

Server: 91.209.0.20 (2.arch.pool.ntp.org)
Poll interval: 2min 8s (min: 32s; max 34min 8s)
Leap: normal
Version: 4
Stratum: 2
Reference: C23ACC14
Precision: 1us (-25)
Root distance: 33.659ms (max: 5s)
Offset: -7.188ms
Delay: 11.153ms
Jitter: 16.189ms
Packet count: 3
Frequency: +88,839ppm

timedatectl timesync-status
Server: 91.209.0.20 (2.arch.pool.ntp.org)
Poll interval: 4min 16s (min: 32s; max 34min 8s)
Leap: normal
Version: 4
Stratum: 2
Reference: C23ACC14
Precision: 1us (-25)
Root distance: 35.582ms (max: 5s)
Offset: -10.308ms
Delay: 11.344ms
Jitter: 17.926ms
Packet count: 4
Frequency: +68,706ppm

systemctl status systemd-networkd systemd-timedated systemd-timesyncd
systemctl status systemd-networkd systemd-timedated systemd-timesyncd
● systemd-networkd.service - Network Service
Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; disabled>
Active: inactive (dead)
Docs: man:systemd-networkd.service(8)

● systemd-timedated.service - Time & Date Service
Loaded: loaded (/usr/lib/systemd/system/systemd-timedated.service; static;>
Active: inactive (dead)
Docs: man:systemd-timedated.service(8)
man:localtime(5)
https://www.freedesktop.org/wiki/Software/systemd/timedated

Feb 09 19:10:02 X1-JOHBR systemd[1]: Starting Time & Date Service…
Feb 09 19:10:02 X1-JOHBR systemd[1]: Started Time & Date Service.
Feb 09 19:10:32 X1-JOHBR systemd[1]: systemd-timedated.service: Succeeded.

● systemd-timesyncd.service - Network Time Synchronization
Loaded: loaded (/usr/lib/systemd/system/systemd-timesyncd.service; enabled>
Active: active (running) since Sun 2020-02-09 19:06:35 CET; 9min ago
Docs: man:systemd-timesyncd.service(8)
Main PID: 503 (systemd-timesyn)
Status: "Initial synchronization to time server 91.209.0.20:123 (2.arch.po>
Tasks: 2 (limit: 18900)

It seems to be all working but my timedatectl status gives a different output. Try and see if this makes any difference.

timedatectl set-ntp true

Then

timedatectl status

Hi

The message is gone, but is replaced with a blinking cursor, but it still takes along time before i am presented with login screen

EDIT
This happend after doing timedatectl set-ntp true

EDIT 2
Just made a reboot and the message is back again

I’m not sure why it’s taking long. What does timedatectl status show now?

You could try and see if restarting it makes any difference.

systemctl restart systemd-networkd

timedatectl status shows it is synchronized
tried to restart but same issue message came back and time is still synced

I can’t look into it any more today will give it ago again during next week.