Virtualbox Extension Installation Error

And that surprises you? You installed it outside the package management.

Again: Do not mix! Your problems are self-made.

As I wrote on Friday, VBox 6.1.0 lies in arch community-testing since Thursday. You can install from it. From anyone and untested from AUR is not necessary.

Okay…Sorry, i didn’t quite get what you were telling me before. This problem all started with an update to virtualbox which i think was the AUR version of the extension 6.1 and i didn’t realize this. It updated and the new virtualbox package is still in testing as you say. So when it updated it wouldn’t install obviously.

Why isn’t the extension coming from Arch in the first place? Then i wouldn’t have to install it from the AUR using yay. I’m just following the wiki as any new user would do. So if it confused me then i’m sure it can be confusing to a lot of people especially new users.

So i guess the best way is to install the extension by downloading it and adding it manually?

This is the first time i have ever had this happen so i just wasn’t seeing it. I’m human … at least i think i am? :disappointed_relieved:

1 Like

How do i install it from the arch community-testing? Do i have to add the repo?

You should make up your mind.

  • Installation from the arch repositories, i.e. via package management. I see it’s out of community-testing, now in community.
  • Installation of the files from virtualbox.org, not via package management.

I use the latter myself in siduction and endeavouros. But this is my decision for certain reasons. I also keep it permanently up to date myself, including dev versions.

Like i said the wiki instructions to install virtualbox uses pacman and then yay to install the extension which is coming from the AUR. I would install the extension from Arch if it’s there!

Hi @ricklinux, the licence stuff doesn’t make it easy about ext pack. Only personal user could install it, take it from the link I gave you up directly from virtualbox website. Follow what told @ringo to do it manually for stability. Name of package :
Oracle_VM_VirtualBox_Extension_Pack-6.1.0.vbox-extpack

To remove your vbox 6.0.14 :

sudo VBoxManage extpack uninstall "Oracle VM VirtualBox Extension Pack"

then check you have nothing before instal your 6.1 :

sudo VBoxManage list extpacks

I saw right now an update

virtualbox-host-modules-arch 6.1.0-1 -> 6.1.0-2

but not sure this is a good idea to do it with versionning from Vbox. The 6.1.0.1 has to work on your new computer.

Thanks …
I just got the new version and installed the extension manually.

Screenshot_2019-12-14_14-00-11

So great you got it, sorry to answer little late…
Could you check about 3D acceleration unchecked to get the VboxSVGA working ?
@FredBezies got it work normally but it seems that now Vbox detect itself which one to use or not in conflict ! So to get the VboxSVGA setup, I have to unchecked the 3D which seems to be active automatically now from Vbox, need to refind where I read this message on Vbox.

Thanks a lot i just didn’t realize that what happened was the extension was updated prior to the new version of virtual-box. That is what was causing the problem but i didn’t see it. It was staring me right in the face. :roll_eyes:

@ricklinux
Seems that the PKGBUILD of virtualbox-ext-oracle is lacking to check virtualbox version compatibility. If there were such a check, then the problem wouldn’t have existed…

1 Like

The only setting that works for the new v-box is VBoxVGA. Otherwise you cannot set your resolution to size and go full screen. I guess some think that running virtual should be just in a box! Hence the name v-box. Not me…i find that useless! :unamused:

Hi @ricklinux, I found a way to get the VboxSVGA with 3D checked on Virtualbox 6.1.0.1.
I think it’s a bug for now depending where you setup it.

1/ First checked the 3D inside the VM settings, and let whatever graphic controler you want.

2/ Close the window setting and click as below directly on the name VMSVGA of your VM

3/ Then a little window appears so change it for VboxVGA and click OK.

4/ Now the VboxSVGA with 3D checked keep right.

5/ To change 128Mo to 256Mo continue the post down, it’s explained

1 Like

When you say general settings. I tried and i just get black screen when launched. I’m not sure where you mean.

Not from this window below but the one I showed you up, don’t enter inside the settings of your VM like we did before but stay on the general view of your VM see picture UP.

Okay … yes i found that i had to change all of them or it would boot to black screen. I had 8 virtual machine setup. Once i changed them all it now works. Thanks!

1 Like

@FLVAL I also wanted to ask when ever you install ANY Cinnamon based distro in v-box it always gives you a notification about video drivers. It works fine and there are no issues but i don’t understand why the message? What is it in the Cinnamon desktop that causes this as it is mostly built off of Gnome isn’t it. Is there any way around this or a way to stop the message from appearing?

could also be a precaution because virtual video card is les power full as real videocard. probably just designed this way

An extra, they designed the new Vbox 6.1.0.1 with 256 Mo in spite of 128Mo ! :rocket:
But to get it, this is only possible for now on the global view of the VM.

5/ Click on the 128Mo then a little window appears

6/ Setup to 256Mo with scroller or button then click ok

7/ Your VM is ready with 3D acceleration on VBoxSVGA 256Mo

Okay i do have that update. This issue has been the same on Cinnamon ever since i ever used v-box. Just Cinnamon nothing else.

Edit: I have virtualbox-host-modules-arch 6.1.0-2