Virtualbox Extension Installation Error

There was an update to virtualbox and now the extension that was installed is messed up. Tried to reinstall it and getting the same errors.

Packages (1) virtualbox-ext-oracle-6.1.0-1

Total Installed Size:  1.63 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                     [----------------------] 100%
(1/1) checking package integrity                   [----------------------] 100%
(1/1) loading package files                        [----------------------] 100%
(1/1) checking for file conflicts                  [----------------------] 100%
:: Processing package changes...
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
(1/1) reinstalling virtualbox-ext-oracle           [----------------------] 100%
0%...
Progress state: NS_ERROR_FAILURE
VBoxManage: error: Failed to install "/usr/share/virtualbox/extensions/Oracle_VM_VirtualBox_Extension_Pack-6.1.0.vbox-extpack"
VBoxManage: error: Failed to load the main module ('/usr/lib/virtualbox/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.amd64/VBoxPuelMain.so'): VERR_FILE_NOT_FOUND - /usr/lib/virtualbox/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.amd64/VBoxPuelMain.so: undefined symbol: RTVfsFileQuerySize
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component ExtPackManagerWrap, interface IExtPackManager
VBoxManage: error: Context: "RTEXITCODE handleExtPack(HandlerArg*)" at line 1361 of file VBoxManageMisc.cpp
error: command failed to execute correctly
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
[rick@cinnamon-pc ~]$ 

Seems like a verification file is missing or not updated for the extension pack. I even downloaded it directly from Oracle and get the same error.

VBox 6.1.0 lies in arch community-testing since yesterday. You can install from it.

But you can also just install virtualbox-guest-modules-arch 6.1.0-1 and from virtualbox.org

  • VirtualBox-6.1.0-135406-Linux_amd64.run
  • Oracle_VM_VirtualBox_Extension_Pack-6.1.0-135406.vbox-extpack
  • VBoxGuestAdditions_6.1.0.iso

Any other VBox packages from the arch repositories must have been uninstalled, which means you can’t mix anything else. The latter works fine, so .run.

Thanks very much. So if i understand you correctly where do i download VirtualBox-6.1.0-135406-Linux_amd64.run? I am assuming download the file and use .run or do you mean something else? Also the virtualbox-guest-modules-arch 6.1.0-1 from the Arch site. Do i just download the file from the mirror and unzip it and then? I’m not used to doing things this way. The extension is usually not a problem to install after. I still have to load the vbox drv and add myself to the users group right? So i need to install the virtualbox first then the guest additions and then the extension pack.

You have to take care of updates yourself.

No. Install as usual and first and only this from arch repositories:

sudo pacman -S virtualbox-guest-modules-arch

Then:

sudo sh Virt*

(Uninstall if desired:)

sudo sh Virt* uninstall

But I don’t have time now, sry.

1 Like

Thanks for your help. I didn’t understand exactly what you meant. I tried installing it as usual and this didn’t work. The sudo sh Virt* was complaining the virtualbox vm was a directory or something.

I downloaded the VirtualBox-6.1.0-135406-Linux_amd64.run and made it executable and ran it to install virtual box. Then i used sudo pacman -S virtualbox-guest-modules-arch to install the guest modules. Then i loaded the vbox drv and added myself to the user group. Then i downloaded the extension pack and was able to load it from virtualbox. I 'm not that familiar with a lot of command stuff in linux but if it’s explained i get it. Well most of the time. :rofl: Hopefully i got this done right. I had to look up the commands to make the file a run file and run it. Thanks for pointing me in the right direction.

Although it loaded the extension properly it’s not working right. It loads the ISO and gets to where it should be at the desktop and just stops. So i will look at it later.

That extent8on pack i have it from virtualbox website directly, and it update itself by vbox. Atleast here

For me the new (6.1.0-1) virtualbox and virtualbox-ext-oracle installed successfully.
Is it possible that your download was corrupted somehow?

So the bug from tonight is resolved by Oracle with the Package virtualbox-ext-oracle 6.1.0-1 ?

https://aur.archlinux.org/packages/virtualbox-ext-oracle/?O=0&PP=10

The ext pack wil update automatical :grin: if you just download from oracle install by vbox just get updatef

One way to install (and get updates as they come!) a pre-built package virtualbox-ext-oracle is to use my unofficial repo.

More info at these places:


It seems the they updated the extension pack now as you say. I ended up having to individually remove vbox files in various locations and was able to reinstall it. Somehow it got messed up when the vbox update installed.

Edit: I’m still getting the same problem. The new updates aren’t working and it loads to here and stops.

I just did a full reinstall of Endeavour and then installed virtual box again. It still is not installing the extensions properly since the updates. :angry:

Screenshot_2019-12-13_13-06-01

Of course you have to be in the path.

Whether you make *.run executable or execute it via sh is irrelevant.

No, isn’t the same. For VMs choose VBoxSVGA not VMSVGA!

The most important thing is, you must not mix versions, especially with relation to their origin (apart for a few exceptions - a matter of experience).

I am choosing VboxSVGA. I don’t understand what your telling me.I have installed it all again and the extension isn’t installing properly. That’s all i know. Is it because it’s not the right version?

The output says otherwise, typical for choosed VMSVGA. Also you could read Xorg.0.log in a tty.

i just did a update , reboooted and open up my virtualbox. and it ask me to update the ext. pack, it downloads and installing it. (after root pasw) en it works…

The choice from @ricklinux for VboxSVGA is due to the WIKI page about VirtualBox installation :

Disclaimer: Without changing Graphics-Controller to VBox SVGA and 3d acceleration enabled the Virtualbox will not boot into Live-Environment!

@ricklinux you could check which pack is running :

sudo VBoxManage list extpacks

then download the Extension pack here :
https://download.virtualbox.org/virtualbox/6.1.0/Oracle_VM_VirtualBox_Extension_Pack-6.1.0.vbox-extpack

And now you could add it easily from the VirtualBox manually.

I have downloaded the extension pack and installed it manually. I get the same result. This has happened since the updated version of VirtualBox. I even wiped out my EndeavourOS install of Cinnamon and installed fresh Xfce. Then I installed VirtualBox no problems. Then when I install the extension pack it has an exclamation mark or similar in it because it’s not installing properly. This frustrates me because I have never ever had an issue with VirtualBox in the past. I’m going to try it on Windows 10 tonight first after work. Then I’m going to see if I can install the earlier version. I just have to figure out which one it is and how to install it. I was using vbox to test with. :weary:

Yep, seems lot of people come back to previous version with this update !
And what gives you before you install the ext pack that you download, seems to a keyring something with your old ext pack (licence stuff) ? With Vbox you could only only use ext pack from the version of your Vbox…

sudo VBoxManage list extpacks