Very low volume

Hi everybody,

I installed EndevourOS with an XFCE desktop and pipewire audio.

The audio volume is very low. If I put everything to the max (alsa mixer, pulse, speakers) I can barely hear the sound, no matter the source (local audio files, youtube, …).

On the same machine, I have a Windows installation and the sound is loud and clear already on medium volume levels. I tried Ubuntu and Manjaro from a live medium an faced the same issue of low volume, so it does not seem to be distribution specific.

  • I already went through the arch wiki concerning low volume without avail.
  • I replaced pipewire-pulse with pulse, without avail.
  • I used pactl set-sink-volume and I can increase the volume to about 200% which gives an audible difference, but still much to low though. Setting values higher than that does not lead to any difference.
  • Other forum posts concerning low volume do not seem to apply here.

amixer output

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]

relevant (?) pactl list output

Sink #48
	Name: alsa_output.pci-0000_00_1f.3.analog-stereo
	Description: Built-in Audio Analog Stereo
	Driver: PipeWire
	Sample Specification: s32le 2ch 48000Hz
	Channel Map: front-left,front-right
	Owner Module: 4294967295
	Mute: no
	Volume: front-left: 99957 / 153% / 11,00 dB,   front-right: 99957 / 153% / 11,00 dB
	        balance 0,00
	Base Volume: 65536 / 100% / 0,00 dB
	Monitor Source: alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
	Latency: 0 usec, configured 0 usec
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.class = "generic"
		alsa.device = "0"
		alsa.driver_name = "snd_hda_intel" = "ALC1220 Analog"
		alsa.long_card_name = "HDA Intel PCH at 0xb3510000 irq 168" = "ALC1220 Analog"
		alsa.resolution_bits = "16"
		alsa.subclass = "generic-mix"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		api.alsa.card.longname = "HDA Intel PCH at 0xb3510000 irq 168" = "HDA Intel PCH"
		api.alsa.path = "front:0"
		api.alsa.pcm.card = "0" = "playback"
		audio.channels = "2"
		audio.position = "FL,FR"
		card.profile.device = "4"
		device.api = "alsa"
		device.class = "sound" = "42"
		device.profile.description = "Analog Stereo" = "analog-stereo"
		device.routes = "2" = "api.alsa.pcm.sink"
		media.class = "Audio/Sink"
		device.description = "Built-in Audio" = "alsa_output.pci-0000_00_1f.3.analog-stereo"
		node.nick = "ALC1220 Analog"
		node.pause-on-idle = "false"
		object.path = "alsa:pcm:0:front:0:playback"
		priority.driver = "1009"
		priority.session = "1009" = "18"
		clock.quantum-limit = "8192" = "35"
		node.driver = "true"
		factory.mode = "merge"
		audio.adapt.follower = "" = "audioconvert/libspa-audioconvert" = "33"
		object.serial = "48"
		node.max-latency = "16384/48000"
		api.alsa.period-size = "1024"
		api.alsa.period-num = "32"
		api.alsa.headroom = "0" = "false" = "false"
		api.alsa.card = "0"
		api.alsa.use-acp = "true"
		api.dbus.ReserveDevice1 = "Audio0"
		device.bus = "pci"
		device.bus_path = "pci-0000:00:1f.3"
		device.enum.api = "udev"
		device.form_factor = "internal"
		device.icon_name = "audio-card-analog-pci" = "alsa_card.pci-0000_00_1f.3"
		device.nick = "HDA Intel PCH"
		device.plugged.usec = "4221590" = "0x06c8" = "Comet Lake PCH cAVS"
		device.subsystem = "sound"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0" = "0x8086" = "Intel Corporation"
		device.string = "0"
		analog-output-lineout: Line Out (type: Line, priority: 9000, availability group: Legacy 5, available)
		analog-output-headphones: Headphones (type: Headphones, priority: 9900, availability group: Legacy 6, not available)
	Active Port: analog-output-lineout

inxi -Aa output

  Device-1: Intel Comet Lake PCH cAVS vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
  Device-2: NVIDIA GA102 High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 01:00.1 chip-ID: 10de:1aef
    class-ID: 0403
  API: ALSA v: k6.4.4-arch1-1 status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 0.3.74 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl

Any help is very much appreciated.

Welcome to the forum!

In my experience, on Linux audio has lower volume than on windoze, that’s just how it is… I can hear the audio output from my laptop’s speakers just fine, but it’s substantially lower volume than on windoze. On my desktop, I’ve never tried it with windoze, but by using speakers with a decent amplifier I have no problems getting really loud audio out of my PC. Of course, this is a hardware solution so it’s not going to work using laptop’s speakers.

I think in your case, it’s just an unlucky combination of having weak speakers and Linux audio being what it is… External speakers will certainly help here. It’s not the ideal solution, I know.


It can only be the reason of really unfortunate combination of Software / Audio-card / DAC, which should be solvable, if that’s the case.

P.S. I speak from direct experience, on about…6 different systems i’ve used with Windoze first and Linux second.

I don’t think it’s bollocks. I’ve had this exact problem on at least 20 PCs I’ve had in my possession over the years (not all my own, but the ones I’ve installed Linux to).

In general, with the same motherboard audio chip and the same amplifier and the same speakers, the volume knob on Linux has to be turned up significantly higher to get approximately the same volume from the same audio file. I haven’t done any specific measurement. I might do that one day, but I don’t feel like installing windoze.

Of course, this is only ever an issue with laptops that have weak speakers. In every other case, it can be easily compensated.

I can have an assumption:

  1. 100% software / OS volume level should be EXACTLY the same (especially in pro-audio context, meaning bypassing all internal OS mixers completely, ASIO in case of Windoze, jack in case of Linux)

  2. Volume of different DE/WM can scale differently, so if you compare something like 66% volume scales - it can be a bit different (say linear vs logarhythmic).

I remember it being a problem in 2004 when I was trying Ubuntu with old ɢɴᴏᴍᴇ, and in 2017 when I was using Ubuntu with Unity, and when Ubuntu “upgraded” to new ɢɴᴏᴍᴇ. And on Kubuntu using KDE. Manjaro, Arch… On Arch KDE and Arch with dwm. And this is with desktop audio set to 100%. If I set it above 100%, like 150%, I get clipping, which is not good.

I’ve just grown used to it, I no longer mind it, but every time I hear windoze audio, I’m amazed how loud it is. Same quality, just bigger volume.

I’m telling you something is not right here, it shouldn’t be the case.


Personally i’ve never used anything than jack for my needs, to avoid all that pulse / pipe crap alltoogether, maybe you guys should check something like that then:

Perhaps default / auto device is not exactly a spring chicken.

P.S. The only valid comparison is 100% volume, don’t go above.

Of course, above 100% you get lower dynamic range and clipping. That’s definitely not desired.

For me, it’s not an issue because I have decently powerful speakers. I set the DE audio level to 100%, play some music, and adjust the volume knob on the amplifier to get a pleasant, if not slightly too loud sound. Then I lower the volume slightly in the DE, to say, 80% and that’s how I run it all the time. If I want to loudly blast some music, I crank up the volume knob on the amplifier.

On my laptop, with internal speakers, it’s definitely an issue, but those are crappy speakers anyway, so I don’t care. I remember that laptop came with windoze 7 preinstalled, and I remember it had pretty loud (though still crappy) audio.

1 Like

btw, it’s also not your fault since a lot of motherboards and laptops use it, but i have to say that Realtek was, is and likely will be absolute CRAP on any platform, their drivers always sucked.

1 Like

Thank you for the reply, but i already set all the relevant levels for this card also in alsamixer to the maximum.

What else could I try? I can accept, that the volume on Linux is lower than on Windows, but in this case I can hardly hear anything even with all volume knobs maxed out.

Thanks again.


Tried switching from default device to specific, like here Very low volume - #8 by keybreak?

I can accept, that the volume on Linux is lower than on Windows

Don’t accept something that is wrong. It’s just something unfortunate, likely in software / settings side in your case…We should find out what’s that.

I also wonder, is this only happen for you with laptop speakers, and not with headphones?


Thanks for all the replies.

Unfortunately, I already tried all of your suggestions and the “solution” from the arch forum with pactl set-sink-volume, as i pointed out in the original question, yielded only a very minor increase in volume.

I skimmed through all the posts in this forum, the arch forum, stack exchange, … which mention a similar problem. However, none of the discussed “solutions” works in my case.

Btw, I am using a desktop computer, with external Logitech speakers, which I also have to set to maximum volume to be able to hear something at all. I don’t have different speakers to test, but I guess they cannot be the problem.

I tried a USB headset, which does not use the sound card (?). They worked reasonably well and I got an acceptable volume. The problem really seems to be related to this specific sound card (chip).


Yeah, sounds a lot like it…But i still doubt it’s unsolvable.
What’s your motherboard model?

also this?

sudo dmesg | grep snd

wow X_X
That Windoze collision thing… :rofl:

The PC is a prebuilt HP Omen GT13 with Motherboard

$ sudo dmidecode --type baseboard
# dmidecode 3.5
Getting SMBIOS data from sysfs.
SMBIOS 3.2.0 present.

Handle 0x0002, DMI type 2, 15 bytes
Base Board Information
	Manufacturer: HP
	Product Name: 8703
	Version: 00
	Serial Number: PKMKE0D0GEJBSO
	Asset Tag:  
		Board is a hosting board
		Board is removable
		Board is replaceable
	Location In Chassis:  
	Chassis Handle: 0x0003
	Type: Motherboard
	Contained Object Handles: 0

and Kernel messages:

$ sudo dmesg | grep snd
[    4.053553] snd_hda_intel 0000:00:1f.3: enabling device (0100 -> 0102)
[    4.053958] snd_hda_intel 0000:01:00.1: enabling device (0100 -> 0102)
[    4.054022] snd_hda_intel 0000:01:00.1: Disabling MSI
[    4.054025] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    4.151036] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC1220: line_outs=1 (0x1b/0x0/0x0/0x0/0x0) type:line
[    4.151039] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    4.151040] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x14/0x0/0x0/0x0/0x0)
[    4.151041] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    4.151042] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    4.151043] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18
[    4.151044] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
[    4.151044] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x1a
[    4.151045] snd_hda_codec_realtek hdaudioC0D0:      Line=0x15

Thanks for your time!


dmesg looks fine, nothing unusual or failed there…

Can you also return this please?

inxi -Maz
1 Like
$ sudo inxi -Maz
  Type: Desktop System: HP product: OMEN 30L Desktop GT13-0xxx v: N/A
    serial: <filter> Chassis: type: 3 serial: <filter>
  Mobo: HP model: 8703 v: 00 serial: <filter> UEFI: AMI v: F.25
    date: 04/28/2023
1 Like

What i wonder is, can you verify in your PC / motherboard manual (i assume your computer had one) which exact model of Realtek chip it has?

I think it might be newer one, than it’s reported / detected in your system right now…
It may be just too new chip which hasn’t been integrated properly in Kernel / alsayet, but i’m not sure.

There was no accompanying manual, but it seems to be this board:

The codec is: ALC3866-CG, which is the same as in this thread with a similar problem:

I bought this PC about two and a half years ago and it was out already some time before, so it is not really new.

Also in principle the card and driver seem to work and I can hear everything, just with a very, very low volume.

1 Like