Using CTRL+F with Firefox in KDE produces a BEEP sound on my motherboard on various distros

Hello friends.

I am new to Linux but have tried Ubuntu, Fedora and now I am only using EndeavourOS as I want it to be my only distro. I’ve tried all of these distros this month, with the GNOME and KDE desktop.

Everything works fine, but when I press CTRL+F, and type something in Firefox, and the search doesn’t find anything and the field appears red, the motherboard beeps. That is to say, physically inside my tower, a loud sound, similar to the one I use when I turn on my PC, but different.

It only happens in firefox with KDE, in the 3 different distros, it doesn’t happen with GNOME. If I use firefox in GNOME, the sound will be heard correctly through the headphones.

My pc is an i-5 3470, nvidia gtx 1050 ti, 8gb ram, gigabyte H61M-D2H-USB3 motherboard.

My pc is quite old, I only have GRUB because my motherboard is very old, but it’s the only one I have.

Maybe it’s a bug that will be fixed over time, but I don’t know. Maybe some of you can help me, since, although it is not too annoying, I would like to solve it, for fear that it drains the battery on the motherboard, or something.

Thanks in advance.


Hi. You can read this wiki:
For KDE see this section:


Thank you very much friend, this solved my problem!

I don’t know if this is the best way to do it, or doing it from the terminal might be better, but I chose this because I’m new to Linux.

Thanks my friend!

1 Like

Thank you very much friend, although I have chosen the option to deactivate it from system configuration > accessibility > bell.

I don’t know if it’s better to do it from the terminal, or if the result is the same.

Thanks again my friend!

By doing it via terminal as suggested, you will block the driver for the device to be loaded and therefore you disable it at the hardware level, so to speak.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.