Is there any way to disable the *BEEP* noise from xfce?

I’m talking about the noise that plays when i press the logout menu or accidentally press the arrow key by mistake.

I tried doing
xset b off
and it worked but it resets itself after every restart. Is there anywhere i can permanently turn that sound off because it blows my eardrums out whenever i have headphones on haha

Thanks <3


su <enter password>
echo "blacklist pcspkr" > /etc/modprobe.d/blacklist.conf

I haven’t been using Xfce for a long while, but if I remember correctly, adding xset b off in ~/.xprofile should turn off the sound.