User password not accepted

i am a new user at endeavour os. Installed it yesterday in the plasma variant and so far I like it quite well.

But since today I have a problem with my user password. It is often not accepted out of the blue. May be it works a few minutes later again, but I could not find a pattern why it then suddenly works again or not.

In the logs I found things like this…

agent-helper-1" hostname=? addr=? terminal=? res=success'
Okt 12 18:40:39 _hostname_ dbus-daemon[528]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
Okt 12 18:40:39 _hostname_ polkit-agent-helper-1[2330]: pam_systemd_home(polkit-1:account): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Okt 12 18:40:39 _hostname_ kernel: audit: type=1101 audit(1634056839.458:122): pid=2330 uid=1000 auid=1000 ses=2 msg='op=PAM:accounting grantors=pam_unix,pam_permit,pam_time acct="_user_" exe="/usr/lib/polkit-1/polkit-agent-helper-1" hostname=? addr=? terminal=? res=success'

What can I do to fix this annoying problem? Please let me know if I can provide more helpfull info.

Regards
sandman

If you enter your sudo password incorrectly (or cancel the prompt) three times within a short amount of time then it will be locked. You can verify by running faillock in a terminal.

Hi Jonathan,

yes, I know this but that´s not the problem. I cancel after second time with ctrl+c after running in the lock before.
The system sometimes really doesn´t accept the right password. Errors due to incorrect keyboard assignment, typing errors, etc. are excluded.
It’s hard to describe. I just rebooted and after successfully logging in with exactly this password, it is not accepted in the console. Or just tried to change an icon in the bar but the ok button is grayed out etc.

The only other thing I can think of is that you have the keyboard layout set to change on a per-window basis, which could explain why it works sometimes but not others.

If that’s not the case then there’s something very, very, odd going on, e.g. a hardware issue.

Welcome to :enos: forums.

Seems I have a clone :stuck_out_tongue: in here. Anyway, can you post the output of id <replace this with your username> here? Enter the command in the terminal.

Sadly I didn´t change anything of keyboard layouts @jonthan.

Ooops… i didn´t know anything about another sandman in here :slight_smile:
Thank you for welcome.
OK, the outpit of id

uid=1000(myusername) gid=1000(myusername) Gruppen=1000(myusername),3(sys),81(dbus),982(rfkill),984(users),998(wheel)

EDIT:
A good example. I tried a sudo command, password not accepted. I didn´t close the window and as you can see for the last given command the password was accepted. Very weird.

I don’t speak German - what do the top two error messages say?

(If you’d copied them in as text I’d have passed them through a translator - one more reason why pasting text output as text is a good thing to do.)

Yeah, you´re right about the text output. Especially it seems I am not good in finding my username in an image :blush: . I just wanted to show both happened in the same terminal session. The error messages only say password incorrect, try again.

I read a bit around here and maybe I should have done it before posting. Found 2 Threads about this. I´ll try the “solution” faillock --reset next time the error will occur.

There are many postings in many forums about those password errors but no real solution.
I can say it´s not systemd related. Had the same few days ago in Artix Linux Plasma and there´s no systemd. Maybe it´s Plasma related.
If faillock --reset will work I´ll be satiesfied for the moment getting rid of this annoying behavour. But it is more a workaround than a real solution .

is there a startup script or app with password requirement, that you eventually cancel with ctrl-c? In other words , would faillock --reset help?

1 Like

How much time is passing between you entering commands with sudo? By default, it sudo will cache the escalation for 15 minutes. That is,

sudo pacman -Syu # will prompt, then immediately
sudo pacman -Syu # will not prompt

If you are being prompted then something on your system has been configured away from the defaults, and if so the question is: what have you changed?

The time between the 2 sudo commands was longer then 15 minutes and I didn´t change any deep system related things. Only appearance and few things in system settings like notifying, network settings etc. @jonathon . But…

@ycom1 gave the decisive tip. I added conky to startup.
i downloaded a template and customized it for my purposes. I did not realize that there are queries in the config that require sudo rights.
Because of the question about a startup script from @ycom1 I disabled the script and restarted the machine. I did several reboots to test and was able to successfully do a sudo pacman right after login each time. The problem seems to be solved.

Now I started conky manually via the terminal and of course the following message appeared

sudo: A password is necessary
[sudo] Password for xxxxx: 
[sudo: password could not be read: Input/Output error

Now the question is how I get this solved with conky. How or where do I start it so it doesn’t cause any problems?

Thank you very much for the quick and competent help.

Generally it’s a good idea to read scripts to see what they do. I don’t think anyone could have guessed this was the cause, so it’s well found.

I suspect that you don’t want to run things from conky that need sudo rights. I can’t think of any reason why you’d need to do that.

1 Like

Don’t run script even conky needing sudo or su or root on your system from the internet. Unless it’s from a well-trusted source.

1 Like

Yes, it was my fault not to read the script carefully. This is almost embarrassing. Usually I take a very close look at something like this. There was a line with sudo that I had overlooked and hddtemp was called there. I have now deleted that.

I like this forum as much as Endeavour OS. Thanks again for the help.

2 Likes

Needing sudo access for conky goodies is a rare thing (especially recently) so If you can post the relevant conky code to me, I can show you a way to get it without a sudo call.

hddtemp is a case in point - I have no idea why it seems to think it needs sudo rights to make a SMART system call, but it does. Assuming that the result from which hddtemp is /usr/bin/hddtemp, then this command will allow conky to call it without a sudo in the script:

sudo chmod +s /usr/bin/hddtemp

I would suggest further research before extending this to other commands that call sudo! Several others that MIGHT have needed it before have been made accessible in other ways, such as in sensors.

1 Like

Thanks for your tip @freebird54. The temperatures of my HDD drives are generally very low (below 40°C/104°F). SSD and NVME are above that, but below 55°C/131°F, so I don’t need conky to show them all the time.

True enough - not NEEDED - but that isn’t the same as not WANTED. Some of us get carried away with the ability to monitor most things by just taking a glance at a conky whenever… Here’s a partial screenshot of my main conky to illustrate!

If I happen to look, there’s a LOT of info in there! :grin: Of course, there;s quite a bit more going on elsewhere with conky too, as can be seen with a cruise through the Show your desktop thread… (various scrollers, todo lists, packages to be updated, an astrolabe etc etc)

1 Like

I absolutely agree with you.
I was even thinking about sending the conky output to a magic mirror. Then i could also see what’s going on on the computer while being in the kitchen making coffee :blush:

If that does what I think it does, then kool idea! I still won’t make coffee though… :grin:

the kitchen is not only for making coffee :wink: