UpdateInTerminal opens very slowly

UpdateInTerminal opens konsole very slowly it takes about 5-10 seconds …
I’ve already updated the mirror list, but that doesn’t change anything.

eos-rankmirrors
sudo pacman -Syyu

Operating System: EndeavourOS
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.93.0
Qt Version: 5.15.3
Kernel Version: 5.17.5-zen1-1-zen (64-bit)
Graphics Platform: X11
Processors: 8 × AMD FX™-8350 Eight-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GT 630/PCIe/SSE2

Please provide the link instead of writing out your hardware.

inxi -Faz | eos-sendlog

thanks for reply!
https://clbin.com/e8Z9r

I just wanted to see what drivers you had installed for Nvidia. I run kde and no issues. Is it konsole opening slow? Or is it the updating that is slow to start?

Edit: What other software have you installed on kde?

nvidia-dkms, v-box-dkms … konsole opens fast also a direct update command works fast
I only see the delay when I click UpdateInTerminal, the issue started about 3 days ago

Okay but when you click update in a terminal it opens konsole. So is it slow to open console? Or is it just slow to start the update?

yes, it takes 5-10 sec. before konsole opens
it seems to me that a connection to an update server is very slow

What countries are you selecting for your mirrors? Are you also selecting the number of mirrors to use?

@cluster
There is an eos-downgrade package that enables you to downgrade eos packages from the eos repo. You could install it and downgrade the welcome package and see if that makes any difference? I don’t know the reason why this would be happening otherwise? :thinking:

1 Like

only germany was selected, I have added belgium, france and downgraded welcome to 3.17.31-1 afterwards, so far no improvement …
p.s.
the delay is also noticeable when opening welcome

I experience this on Cinnamon as well, with intel drivers for graphics. It’s the opening of the terminal from the Welcome app that is slow for me. If I open a terminal from the Taskbar then it’s fast. I don’t think it’s mirrors that is the problem because if i run paru manually it also goes fast.

some relevant logs from history

[2022-05-03T13:16:43+0200] [ALPM] upgraded eos-bash-shared (1.12-1 → 1.13-1)
[2022-05-01T18:21:22+0200] [ALPM] upgraded pacman-mirrorlist (20220410-1 → 20220501-1)
[2022-05-01T18:21:22+0200] [ALPM] warning: /etc/pacman.d/mirrorlist installed as /etc/pacman.d/mirrorlist.pacnew
[2022-05-01T18:21:22+0200] [ALPM] upgraded eos-bash-shared (1.11-5 → 1.12-1)
[2022-04-30T11:26:31+0200] [ALPM] upgraded welcome (3.17.31-2 → 3.18-4)
[2022-04-30T11:26:31+0200] [ALPM] upgraded eos-update-notifier (1.15.3-1 → 1.16-2)
[2022-04-30T11:26:31+0200] [ALPM] warning: /etc/eos-update-notifier.conf installed as /etc/eos-update-notifier.conf.pacnew
[2022-04-30T11:26:31+0200] [ALPM] upgraded eos-bash-shared (1.10.42-1 → 1.11-5)
[2022-04-29T09:06:33+0200] [ALPM] upgraded curl (7.82.0-3 → 7.83.0-1)
[2022-04-28T11:25:26+0200] [ALPM] upgraded r8168 (8.049.02-72 → 8.049.02-73)
[2022-04-28T11:25:26+0200] [ALPM] upgraded linux-zen-headers (5.17.4.zen1-1 → 5.17.5.zen1-1)
[2022-04-28T11:25:23+0200] [ALPM] upgraded linux-zen (5.17.4.zen1-1 → 5.17.5.zen1-1)
[2022-04-28T11:25:21+0200] [ALPM] upgraded linux-headers (5.17.4.arch1-1 → 5.17.5.arch1-1)
[2022-04-28T11:25:17+0200] [ALPM] upgraded linux (5.17.4.arch1-1 → 5.17.5.arch1-1)
[2022-04-27T08:21:29+0200] [ALPM] upgraded geoip-database (20220315-1 → 20220419-1)
[2022-04-27T08:21:29+0200] [ALPM] upgraded modemmanager (1.18.6-1 → 1.18.6-2)
[2022-04-26T11:26:55+0200] [ALPM] upgraded bind (9.18.1-1 → 9.18.2-1)
[2022-04-22T17:31:32+0200] [ALPM] installed net-snmp (5.9.1-3)

If I enter the command directly in konsole there is also a delay

UpdateInTerminal --nt

and

sudo pacman -Syyu

works without delay

 core                                               156,2 KiB  1905 KiB/s 00:00 [----------------------------------------------] 100%
 extra                                             1699,9 KiB  30,2 MiB/s 00:00 [----------------------------------------------] 100%
 community                                            6,6 MiB  48,1 MiB/s 00:00 [----------------------------------------------] 100%
 multilib                                           174,1 KiB  14,2 MiB/s 00:00 [----------------------------------------------] 100%
 endeavouros                                         31,7 KiB   633 KiB/s 00:00 [----------------------------------------------] 100%

Hmm, I can’t replicate the issue either on Plasma and Xfce (both bare metal installs) but I don’t have Nvidia onboard. Perhaps @manuel can shed some light on this?

was 6 days ago the last change to u-i-t …

1 Like

But @ricklinux and I don’t have that delay the others described, the terminal (and welcome) opens immediately.
They are talking about the opening of the terminal window, not the update process itself.

well I have the issue for about that sort of time now…I think.

i3 :wink:
As far as i understand this is having the lag? opening UpdateInTerminal from menu?

2 Likes

means downgrade eos-bash-shared?

Yes

2 Likes