Updated driver leads to issue (NVIDIA)

I have had issues with updates and updating, I have fixed it unconventionally, story to follow.

General hardware info in the screen shoot above.
The issue is that I needed to run Davinchi Resolve, It
installed but would not run, complaining about the graphics card drivers.
So I went and tried to install dkms(nvidia) driver, but still no go on the DavinchiResolve.

I went and tracked down the correct driver from Nvidia’s website, see title bar in pic and
general error.


This I accepted and after a few ok’s and are you sure you want to do this I
had it the driver installed and Davinchi ran, win win right kinda. I rebooted.
And found myself with a failed system and had to login to tty. Rerunning the
Graphics driver fixed the issue with graphical login as result, next the real issue.

The problem I now have is that I receive prompts from the system a few days
This keeps appearing and is getting annoying every few hours.
How to fix it? I need the computer for video editing/playing games …

On a side note how to disable the update system pop from EOS this pops,
sometimes 3-4 times a day with “updates available” This is becoming again tiresome.
I usually try and update once a day every day.

sudo pacman -R eos-update-notifier

Expect problems with updates. Manually maintaining the nvidia drivers can be painful.

Installing the driver blob from the NVIDIA website is not the best option - it’s better to use the driver packages that are in the repositories already (whether directly installing using pacman or using EndeavourOS’ nvidia-inst tooling).


Thanks for that Done.