NVIDIA how to do it right

I did this wrongly last time according to the EOS community the good advice I got that I quote above along with the install path I chose last time.

I wish to install and do this right this time, what to choose:
I have a “NVIDIA GeForce GTX 1070” running on “nouveau” driver, how best to proceed?
Before someone says use EOS’s nvidia tooling, Iam on Arch now.

I have to install the nvidia drivers because Ile 1. be playing games an 2. I will be using Davinchi resolve.


In which case, asking on the Arch forum would be the better option.

Of course, before then, you’d read the Arch wiki page that details how to install the NVIDIA driver: https://wiki.archlinux.org/title/NVIDIA


Unfriendly but helpful thankyou, I will look.

Oh, I’m sorry! What would have made my response friendly? Please do tell.

1 Like


  1. the link points to helpful information thanks it dose say though to visit NVIDIA site and see the
    them for the driver. Exactly how I did it last time : which was deemed by some as incorrect.

  2. not wanting to stir trouble, I can point you to information on this as far as EOS is concerned they could not care which version of OS you have along as it uses Pacman or Arched derivative.

I hope that helps you.


It says that is one option to find out the driver version you need for your GPU, not that you should download the driver blob.

Sure. But given you’re using Arch then using the Arch support routes is the better option.

Not really - I still don’t see how what I said was unfriendly. Was it because I didn’t reply with the copy-paste answer of

sudo pacman -S nvidia-dkms nvidia-utils lib32-nvidia-utils

that would have installed the driver without you needing to read the wiki page?

But then, surely posting a single line like that is also not very friendly? Should I be using emoji or animated gif in my posts to make them seem friendlier? :thinking:

(Oh, you’ll also need to add nvidia_drm.modeset=1 as a kernel parameter)





we may add a dedicated Archlinux subforum ?
NAh joking :clown_face:

There is nothing wrong with using arch and asking questions here.
But it is also valid point to ask at the archforum if you are running arch.

I see no need to call someone unfriendly mentioning this and also no need to discuss this widely.
I hope you both cleared that now ?



Iam now at the tty, having installed packages and rebooted. I did not install the " nvidia_drm.modeset=1 as a kernel parameter"

Arch won’t boot.
I did research and decided to go for it(installing drivers etc). Any help is greatly appreciated. Neofetch still says I am on nouveau drivers.

Edit: Reword and info added


installing nvidia-dkms will blacklist nouveau but could be neofetch gave you a false detection if running in TTY ?

If not it could be installing the needed packages was not working (just taking a look into :crystal_ball:)

So first of all give some needed info like the exact full output when installing packages, and the kernel parameter needs to be added in any case:

DRM kernel mode setting

To enable DRM (Direct Rendering Manager) kernel mode setting, add the nvidia_drm.modeset=1 kernel parameter.

wiki says :wink:

If you are using grub the most common way is to add it to grub boot kernel parameter implementation:

Which packages?

In what way? Where does it get stuck? If you chose the DKMS package, did you install base-devel and the headers for your kernel so you could compile the DKMS module?

How are you getting this information if Arch won’t boot?

Do you have ibt=off kernel parameter?

Let me be friendly and unhelpful by mentioning that ever since I moved away from NoVidea to AMD, my quality of life has improved tenfold, at least regarding my use of computers.

Life is good without NoVidea!



The packages that you said for Nvidia

I got stuck, after trying to load linux, so after grub
No I did not do base-devel
AS previously stated I did not do kernel module(compile DKMS) I was not told to.

As previously stated I was able to reach TTY.

When I say Arch wont boot I mean it fails/get’s stuck at early stage.


OK, so you just need to install base-devel and the headers for your installed kernels (e.g. linux-headers for the linux kernel) then trigger a rebuild of the DKMS module with dkms autoinstall.

If you pay attention to the output of commands you should be able to spot problems before rebooting.


Thanks for your post @jonathon
The plain fact Iam trying to do what you say however I don’t know HOW especially the mucking around with the kernel. Gives me quivers.

Yes I pay attention, I was able to fully reboot by
sudo pacman -Rdd Said packages(nvidia).



I always installed nvidia via pacman with my GTX 1060

sudo pacman -S nvidia nvidia-utils nvidia-settings lib32-nvidia-libgl 

If you are using the dkms version then you need the headers installed also for the kernel being used and also i would have base-devel

A lot has changed with nvidia drivers also. You can use nvidia_drm.modeset=1 as a kernel parameter in the default grub command line and then update grub. Sometimes ibt=off is also required as a kernel parameter.

Of course on EndeavourOS i do things differently now.

I’m not sure how much more information I can provide - I’ve given package names and commands. Which bit are you struggling with?

Hi, Thanks. @jonathon
How Exactly do I add the kernel parameter to grub? I have navigated to /etc/default/grub and nano’ed grub not much to the file but what exactly to add “nvidia_drm.modeset=1”. Do I append it to the end of the file and exit?
Then if I understand everyone I must update-grub ? sudo pacman -Syu grub??

You see the problem, Ive got to understand the process, if I get it wrong what happens and how to recover without wiping out the drive and going again. That I can do but it wont get me far. It’s what testers do install and reinstall and test. But this is the main computer daily driver. I have windblows but I had rather not thanks.

Last time I installed those drivers(nividia) there was a problem, I have yes me have to work out what it was and report back here.
Edit: just done
sudo pacman -S nvidia nvidia-utils nvidia-settings lib32-nvidia-libgl
I no error this time. Still to update grub.


What you are doing is correct. Use nano and edit /etc/default/grub. You can add it to the end. Don’t forget you have to save the changed file first. With nano you just use:

ctrl + o then enter to save
ctrl+ x to exit nano

Then you have to run the update grub command

sudo grub-mkconfig -o /boot/grub/grub.cfg

@jonathon Hope it’s okay for jumping in here. :slightly_smiling_face:

1 Like