Update problem, Keyrings problem, startup failed to execute eos_yad and more


I think I have messed up and i would need your help if you are so kind to provide it! :slight_smile:

tl:dr I can’t use updates anymore. endeavouros-keyring gone by my mistake

  1. When i booted today i got this error

  2. I tried to search for it and didn’t find anything relevant so I started my morning routine by updating the system with eos-update --yay and it successfully updated alsa and pipewire.

  3. I got some problems with updating some packages though (anaconda,yacreader and dwarfs-bin), it wrote
    error: failed to commit transaction (conflicting files)”.
    I checked the advice of https://wiki.archlinux.org/title/pacman

    and thought that was a conflict of same files so I WRONGLY used pacdiff & meld and overwrote 4-5 entries with ‘o’.

  4. Thats when my troubles began because when i re-run update I had the problem of “error: target not found: endeavouros-keyring

I tried the solution provided here Keyring Issues , deleted (idiotic move from me) the gnupg folder in pacman.d, but then I could not use wget in the addresses provided because they were no longer existent :frowning:

Then i tried many things from here (including the populating keys and refreshing them

sudo pacman-key --init
sudo pacman-key --populate archlinux endeavouros
sudo pacman-key --refresh-keys
sudo pacman -Syy

but no luck!

Any suggestions or could you point me to the right urls to retry wget?

Thank you and sorry for the trouble!

I would work through the steps in this guide.


Thank you for replying!

Unfortunately it can’t find the endeavouros keyring at all

also yad is newer than extra and it seems that now I dont have the other databases besides core/extra :frowning:

  • I confirm that my system clock is correct.

  • I confirm that my folder /var/cache/pacman/pkg/ is empty

  • I confirm that i dont have incomplete downloads

  • I backed up the -newly created- gnupg folder

  • initialized the keys and repopulated them (both for endeavouros and arch)

  • again it doesnt find the endeavouros keyring

  • and it doesnt find the keyring packages



and try update again

Unfortunately no dice

the endeavouros repo does not sync
please post the output from:

cat /etc/pacman.conf

Sure thing!

(Sorry i am not familiar yet on how to post outputs in a better format than pntscn)

these lines are missing

SigLevel = PackageRequired
Include = /etc/pacman.d/endeavouros-mirrorlist

insert them as in the following standard file

1 Like

text blocks:

like this


like this

use the code tags(</>) from the forum editor and insert the terminal output in it.

1 Like

That was it!!!
Now I can at least update!
Thank you very much for your patience and thoughtful insight!

Btw do you guys have any idea for this error that still keeps popping up?

Also I still have the error of not being able to update anaconda and dwarfs-bin but I am now trying a cleanbuild. Fingers crossed

1 Like

the error points to your home directory cache folder chances are it has been removed.as far as anaconda and dwarfs-bin i don’t use those so i couldn’t tell you what the issue is

1 Like

Yeap! I thought the same, but I cannot understand what element of eos_yad is this and how it is related to my startup processes. :thinking:


This looks like an error message you’d get on Windows! :thinking:

1 Like

I dont know what to do with that information :sweat_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.