Keyring Issues

Unable to update getting keyring errors. Will not update keys. Cannot import keys.

:: Proceed with installation? [Y/n] y
(75/75) checking keys in keyring                   [----------------------] 100%
downloading required keys...
:: Import PGP key 7258734B41C31549, "David Runge <dvzrv@archlinux.org>"? [Y/n] y
error: key "David Runge <dvzrv@archlinux.org>" could not be imported
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
[rick@endeavour-os ~]$ 

Resolved:
Deleted the gnupg folder in etc/pacman.d
wget https://github.com/endeavouros-team/mirrors/releases/download/mirror2/endeavouros-keyring-1-4-any.pkg.tar.xz

wget https://github.com/endeavouros-team/mirrors/releases/download/mirror2/endeavouros-mirrorlist-1-10-any.pkg.tar.xz

sudo pacman -U endeavouros-keyring-1-4-any.pkg.tar.xz
sudo pacman -U endeavouros-mirrorlist-1-10-any.pkg.tar.xz

sudo pacman-key --init
sudo pacman-key --populate archlinux endeavouros
sudo pacman-key --refresh-keys
sudo pacman -Syy

sudo pacman -Syu

1 Like

also had issues with endeavouros keyring and mirrorlost?

edit; since key issue of archlinux side, reinstalling keyring and mirrorlist is not needed the higlighted is the main solution.
:slight_smile:

I probably went overboard but i tried the keyring first and only deleting the gnupg folder seemed to work. I tried for an hour messing with it before I got it to finally work and install the updates. Just on one computer though.

removing the gnupg and doint the pacman-key commands especially init option does the job generaly