Update incl. kernel 6.3 killed native monitor resolution

Hi, after updating all my packages recently I lost the ability to run my monitor at its native resolution (2560x1440). The option still appeared in xrandr/arandr but the monitor simply got no signal if I switched to it (1080p worked fine). After trying different things for the better part of a day I downloaded an older kernel (I was on 6.3.1, I switched to 6.1.27) the resolution comes back, although I’m seeing some visual bugs on my i3 desktop. Has anyone else experienced display issues after recent updates?

FYI using onboard AMD graphics (amdgpu driver) and i3/X.

I realized I probably went back to far so I went up to… things are still a little off but still trying things.

Kernel 6.3 and 6.2 work fine for me with the resolution 2560x1440 and AMD graphic.

The problem would be with your desktop environment:

@Zesko could you explain a little more? I’ve tried switching Kernels multiple times here and still none of the newer ones worked. When I went back to 6.2.x it worked fine. As of Kernel 6.4.1 still having this issue, kind of driving me crazy. I don’t have such an unusual desktop here I don’t think, am I really the only one experiencing this?

So, it’s not specific to my desktop setup I don’t think. I get exactly the same behavior when I boot latest EndevourOS installer from USB. Older version of the installer, pre-6.3 kernel, displays fine. Tried booting installers for Manjaro and Ubuntu, neither of which are using the 6.3 or 6.4 kernels yet, and they both display fine. So it feels like something must have broken the AMD drivers in the latest kernel versions.

Found this post in the fedora forums that suggests the same - that it is not distro/DE specific:

As I’m reading more about this I’m wondering if there might be some issue with AMD microcode not being loaded correctly? One would expect that, given how frequently updates seem to code out, that this would not be left broken for long for a fairly common Ryzen processor.

1 Like

Sorry to spam anyone following this, but seeing other threads recommending people always just use the LTS kernel, which is 6.1.38 and works fine. I’ll just stick to that and stop worrying about this for now, and maybe try a newer kernel again in 6 months or something to see if the issue is resolved.

1 Like

you might also be interested in this thread.

Thanks @pycrk , the problem described in the bug you link to there is kind of the opposite of what I’m experiencing. Lower resolution modes do work on my monitor, it’s just the native resolution that goes black. But who knows maybe related.

1 Like