Broken system after update

I have a brand new PC that’s been running EndeavourOS pretty fine for some months.
Today I updated the system and it’s now broken.

The system boots, flashes a bunch of lines (cannot see any erros, looks fine), but when the UI is about to load it just hangs, nothing shows.

So I booted from an EndeavourOS usb stick to see if that would work. It did, no problems there.
I then tried to reinstall the OS. First with online install with cinnamon. After all is done, I have the same problem.
Then I try offline install, and after it’s done it works fine and boots into UI desktop, BUT after updating the system again everything fails like before when booting…


  • AMD Ryzen 7 7000
  • Gigabyte B650 Gaming x ax
  • 32 GM ram

I’ve searched around to see if anyone else has this problem, but haven’t found anything recent…

Any ideas?

there are currently some problems with the new amd driver, a patch is apparently in the works.

It would probably be useful if you shared which packages you updated that causes the problem after rebooting.

try a kernel downgrade under version 6.3.9-arch1-1
or the LTS kernel

Well, this happens after a “stock” install with only packages that is installed by the default system. The system is also broken, I cannot even get in.

Yes, any tips on how? I cannot even get a shell

Edit: I will try to reinstall and add the LTS kernel, maybe that will help

I tried reinstalling with LTS and booting from it, but unfortunatly still same problem.

I’m assuming the bug you mentioned is not present in LTS, so then this must be some other problem?
(just checked, the LTS is 6.1.36, so this is not the problem)

There is just no signal sent to the monitors, so CTRL+ALT+F2 to get a shell doesn’t work

You made it sound as if that after a fresh “offline install” you reboot the system, then update and that you then run into the problem as well. Do you remember which packages you update before you reinstall your system?

I managed to film the booting sequence and pause it to see the last thing happening before it goes dark…

You can boot from the EndevourOS live media, then mount your filesystems to a location within the live environment and then chroot into your system.

No, I would have to reinstall to debug, but I can do that

Good to know, thanks, might come in handy another time

LTS was updated today, it may also be affected


you could chroot into your system and then install the appropriate kernel. It would be easier to reinstall(offline) your system and then ignore the kernel in the /etc/pacman.conf file.

e.g. like this

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
IgnorePkg   = linux
#IgnoreGroup =

then you could update your system. so the kernel is ignored when updating
if a newer kernel fixes the problem, you can remove the kernel from pacman.conf again.


if you can boot live session you do not need to reinstall again and again simple use arch-chroot to fix installed system from the live session…

From within the arch-chroot you can run any command (its root by default) as you would run the installed system (inside the chrooted terminal only to make sure)

The issue mostlikely about the GPU driver and Mesa ?
Is the CPU equipped with GPU? or do you have dedicated GPU graphics card installed?

inxi -Gaz from live session would help to see details…

And I forgot to add, after that you can do you troubleshooting and also install packages such as the lts kernel.

Sweet, this did the trick and confirms that the problem actually was with the kernel.

I added linux linux-headers linux-firmware to /etc/pacman.conf and the offline installer works after updating it.

Ok, so isn’t it pretty bad that the LTS kernel is updated to include this bug? Kind of defeats the purpose of LTS…

Anyway, thanks a lot! I will probably reinstall the system again and downgrade the kernel as instructed here. It will be something that is nice to learn

1 Like

Thank you very much, I will try to use arch-chroot to downgrade the kernel now that we found out it was indeed the root cause of this issue.

The motherboard has a graphics card integrated which I’m using, so I guess that’s the problem here!

[alf@studio ~]$ inxi -Gaz
  Device-1: AMD Raphael vendor: Gigabyte driver: amdgpu v: kernel arch: RDNA-2
    code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: DP-2,HDMI-A-1 empty: DP-1,DP-3
    bus-ID: 0f:00.0 chip-ID: 1002:164e class-ID: 0300 temp: 37.0 C
  Display: x11 server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 3840x1200 s-dpi: 96 s-size: 1016x317mm (40.00x12.48")
    s-diag: 1064mm (41.9")
  Monitor-1: DP-2 mapped: DisplayPort-1 pos: right model: Dell U2412M
    serial: <filter> built: 2013 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
    size: 518x324mm (20.39x12.76") diag: 611mm (24.1") ratio: 16:10 modes:
    max: 1920x1200 min: 720x400
  Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: primary,left model: Dell U2412M
    serial: <filter> built: 2013 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
    size: 518x324mm (20.39x12.76") diag: 611mm (24.1") ratio: 16:10 modes:
    max: 1920x1200 min: 720x400
  API: OpenGL v: 4.6 Mesa 23.0.0 renderer: AMD Radeon Graphics (gfx1036
    LLVM 15.0.7 DRM 3.49 6.2.8-arch1-1) direct-render: Yes

From the following comment from the link I posted earlier, I understand that the previous LTS version(6.1.35) was also affected. It would make sense not to update LTS so often, i.e. to put it in the IgnorePkg of pacman.conf.

I’ve done some more debuging regarding what messes things up for me. It is not the kernel directly but the linux-firmware package!
The onces in the red box doesn’t work


After rolling back this to the 25-Apr-2023 version everything works fine, meaning linux and linux-headers works in their latest version


Just to follow up on this.

I finally was politely redirected to the correct issue for my problem: