Update broke network module again

So I did update the system today, and it broke my network connection once again. This time is the problem again can not be solved by the previous methods known to me. I’m at a total loss here, what to do…
I got this message after update:
Missing AUR Packages: 8192eu-dkms grub-tools grub2-theme-endeavouros ipw2100-fw ipw2200-fw nvidia-installer-db nvidia-installer-dkms rtl8192eu-dkms-git

I found a similar topic here After update get missing AUR packages message? , however in my case the update broke network connection.

When I installed the system for the first time, I used this module rtl8192eu-dkms-git for network adapter. It worked fine for several months, but after an update it stopped working. Then I installed 8192eu-dkms using the command ( PC doesn't see Wi-Fi adapter after update ) :
yay -Sy --noconfirm 8192eu-dkms
and this kind of worked for a while (there were a lot of glitches, network adapter hanged my PC, when it required half an hour to reboot, etc. but at least it worked to some degree). Now my PC can not use any of these two modules anymore.

This network adapter has been a real pain in the arse. Is it possible to get it working properly? Or should I just buy a new one and hope it will be more compatible?

I am not sure what the history is but it looks like the AUR package you need is called rtl8192eu-dkms

I would try removing the driver you have and install that one with:

yay -S rtl8192eu-dkms

As a side note, never use yay -Sy. That is a good way to break your system.


Thanks, it worked!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.