After update get missing AUR packages message?

Just did an update via pamac app, rebooted, and in terminal after i run yay I got
:: Searching AUR for updates…

    Missing AUR Packages:  ipw2100-fw  ipw2200-fw

Why is this and how to resolve? tks

Most probably, these packages have been installed as dependencies of other packages in your system which no longer require them. They are not in the repos anymore and that’s why the package manager “thinks” that they must have been installed from other sources, in this case, from AUR.

You can check:

pactree -r ipw2100-fw 
pactree -r ipw2200-fw

to make sure nothing is dependent on them and then uninstall them.


I believe those packages were dropped from the repos.

If you don’t need them, you can remove them.

It is firmware for old Intel network hardware I think.

More likely they were installed by the installer.


same here on new installation.

[ainz@archlinux ~]$ yay
[sudo] password for ainz: 
:: Synchronizing package databases...
 endeavouros is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do
:: Searching databases for updates...
:: Searching AUR for updates...
 -> Missing AUR Packages:  ipw2100-fw  ipw2200-fw
 there is nothing to do
1 Like

Welcome to the forum!

The answer is the same as above. If you don’t need those packages, remove them.


We need to remove it from the installer:

1 Like

Thank You!

1 Like

I get
$ pactree -r ipw2200-fw
$ pactree -r ipw2100-fw

$ pactree -r ipw2100-fw
seems doesnt list as dependencies for other packages?

is ok to remove? how to remove safely?

Yes. Just removed it. No issues.

  • ipw2100 is for Intel PRO/Wireless 2100 802.11b chipset.

  • ipw2200 is for Intel PRO/Wireless 2200 802.11bg and 2915 802.11a/bg chipsets.

It was installed by the EOS Calamares installer as mentioned by @dalto and @sradjoker

1 Like

It is firmware so their is no need to run pactree in this case.

You don’t need them unless you have that specific hardware in your system.

1 Like


Fairly new user with no issues so far.

However, when running yay -Syu I receive the following message:

Missing AUR Packages: ipw2100-fw ipw2200-fw

Looking at the Wiki I understand these are to do with Intel chipsets but have now been removed from the AUR. Am I okay to remove these? Is there a way to make it so any checks of the AUR in the future ignore these components?

Just looking for a little guidance. Thank you.

1 Like

Just remove with
yay -Yc ipw2100

They have been removed from the repos, not AUR.

You should remove them unless your system contains the specific hardware they are referring to.

For cleaning unneeded dependencies:

yay -Yc

To remove ipw2100:

yay -R ipw2100
1 Like

Just saw your message. I ran

$ yay -Rns ipw2200-fw

checking dependencies…

    Package (1)  Old Version  Net Change
    ipw2200-fw   3.1-8         -0.55 MiB
    Total Removed Size:  0.55 MiB
    :: Do you want to remove these packages? [Y/n] y
    :: Processing package changes...
    (1/1) removing ipw2200-fw                          [----------------------] 100%
    :: Running post-transaction hooks...
    (1/1) Arming ConditionNeedsUpdate...
    [simoo@simoo-modern14b5m ~]$ yay -Syu
    :: Synchronizing package databases...
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
     endeavouros is up to date

seems OK now, doesnt say missing packages anymore, thanks all.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.