[UNSOLVED] I Need Help with Installation to Computer with Two Hard Drives

I have an Alienware AW17R3-7092SLV 17.3" FHD Laptop (6th Generation Intel Core i7, 16 GB RAM, 256 GB SSD + 1 TB HDD) NVIDIA GeForce GTX980M | SERVICE TAG 73Z3P72 which I purchased in 2016.

I had EndeavourOS installed to it in Legacy mode. With the latest updates, I started having problems so I decided to completely reinstall the system, this time activating UEFI but leaving Secure Boot disabled.

The installation (using the latest available ISO) seemed to go perfectly and, when I rebooted, the system started perfectly.

Then, without doing anything else, I updated the system using yay.

When I rebooted, the system would not start at all.

This computer has two hard drives: a 256 GB SSD and a 1 TB hard drive. When I installed the system, I had to manually configure the drives (after deleting everything that had previously been installed using GParted) and here is where I ran into questions, the answers to which I cannot find.

I created a 300 MG FAT32 file for UEFI and the rest of the SSD was formatted as EXT4 and set to mount at /

Then I set the 1 TB hard drive to mount at /Home

I added the flag /Boot to the main portion of the SSD.

I did not add any Flag to the 1 TB hard drive. Should I have done so? And if so, what should the Flag be?

By the way, this computer has given me plenty of headaches since I have owned it. I have tried a number of GNU/Linux distributions and none were fully satisfactory. EnOS worked for the longest period of time on it but now it doesn’t work either. Other than Secure Boot being disabled, I have the UEFI/BIOS set to its defaults.

Thanks for any help with this. I should really appreciate it.


Thanks for any help.

Are you getting an error? How far in the boot process are you getting?

EDIT: I know I didn’t answer your questions but the short version is if your system booted up properly after the install and didn’t fail until you updated it with yay there shouldn’t be an issue with your disks/partition setup.

1 Like

I suppose the boot flag should go on the 300mb efi partition. Also, did you set its mount point to /boot/efi?

1 Like

Dear dalto,

I’m going to reinstall the system again (after all, it takes only about 8 minutes). What Flags, if any, should I add?



1 Like

Maybe this is a problem here?

1 Like

I think I did that. But what Flag, if any, should go on the /Home partition?



1 Like

The EFI partition needs to be identified as an efi partition. That is about it.

Unfortunately, every tool seems to label this differently and I don’t have the installer open in front of me at the minute. It will be something like efi or boot.

1 Like

I suppose no flags are needed. (I’ve managed to run home partitions without any flags). But @dalto will be a better person to confirm this.

1 Like

I am not, and have never used, the Nvidia drivers. I use only the default Intel one.



None. There really is no concept of flags needed for a UEFI install.


I had that partition Flagged correctly (I think). It’s the other partitions about which I am concerned regarding Flags. If any are needed, what should they be?

Thanks to everyone here responding to me.


None are needed.

Although, again, this doesn’t sound like a partition/disk/flag issue to me. I suspect it is something else entirely.


Thank you dalto. I shall reinstall the system again, this time using no Flags and I’ll see what happens. I’ll be doing this later this afternoon and I’ll report back here the results.

Again, I wish to thank everyone who has responded to me here. I’ve said it before but I’ll say it again: this is by far the best Linux forum to which I have ever belonged.



By the way, did you really mount partitions to /Home and /Boot (starting with capital letters)? The mount points should start with small letters…

Also, could you please show the output of command

lspci -vnn | grep -PA9 'VGA|Display|3D'
1 Like

I mounted the partitions to /home and /boot. Sorry for the capitals. (My memory isn’t what it used to be.) When (if!) I get the system installed, I’ll post the output of the command you write. That will be later today or tomorrow.

Thank you.


Take your time, I’m not going away! :smile:

By the way, it is possible to do also with the terminal on the live user (USB installer).



If you set up your partitions first and are using gparted and you set the flags in gparted the 300 MB fat 32 will be flagged as /boot/esp in gparted if you use the manage flags in gparted. The other partition would be just formatted ext4 and you may or may not use a swap partition.

Then when you run the installer and you select manual partitions and edit each and mark the 300 MB efi partition as /boot/efi and flag it boot in the window below but keep the fat 32 and not format it if you already done this with gparted… If you watch you will see the installer changes it to /boot/efi when you do this. Then you edit the /root and mark it as / and also if you’ve already formatted it in gparted you can keep and not format it again. You would also select the other drive here and flag it /home and also if it’s already formatted to /ext4 then your good.

Gparted flags the efi partition as /boot/esp. The installer sets it as /boot/efi if you watch what is done when you set these in manual partitioning.

1 Like

are you mixing type partition GPT (/) on SSD and MBR (/home) on hard drive ?
this cant work

1 Like

I LOATHE this Alienware computer!

I have spent the last THREE (3) hours working to get EndeavourOS installed and to get my programs installed (using the yay -S $(cat complete_installed_packages.txt |xargs) --needed --noconfirm command).

Well, I’ve accomplished everything - but it’s still not right.

When I installed (or tried to install) EnOS last week, and after updating after installation, the computer would freeze at a black screen just when LightDM should have been activated.

Thinking that this might be due to the Kernel 5.10.x, this time, before rebooting, I installed pamac-all.

Then, finding the latest lts kernel and its headers, I installed those.

Next I installed grub-customizer.

After configuring that, I rebooted.

The same thing happened. I got a black screen just before LightDM should have activated. Nothing could be done on this black screen.

I turned off the computer and started up again. This time I selected Linux-lts and the LightDM came up and the computer booted fine.

Thinking that maybe the problem was with LightDM, I installed GDM and, after disabling LightDM, I enabled GDM.

Then I rebooted but GDM made absolutely no difference. So I have gone back to LightDM.

What can I do? This computer just will not boot into the 5.10.x kernel. Could this have something to do with the BIOS? I do not know how to update the BIOS (it appears to be Dell specific).

What I am afraid of is that once the lts kernel is upgraded to 5.10.x-lts (and that’s probably coming soon), this computer may not work at all.

I would really like to tell you what I think of this computer but I can’t express myself in a manner suitable for polite company.

If anyone can help me with this ridiculous situation I should be most grateful.


P.S. " I can handle things. I’m smart. Not like everybody says, like dumb. I’m smart and I want respect!"

1 Like

No. All partitions are GPT.