Unable to tag .ogg files (both Vorbis and Opus)

I’m downloading and producing music. I tend to output to .ogg for benefits. Usually, I use something like EasyTag to tag the files. I have recently started messing with audio files again.

EasyTag (and every other tagger program that I tried) doesn’t see the .ogg audio files. None. I will navigate to the directory in EasyTag and the files will not even appear. It appears in my file managers. I have tried downloading packages such as libvorbis, libopusenc, you name it (anything that came up under pacman -Ss opus really), thinking I was missing some library or API. To no avail.

Am I missing something here? I have no idea where to go from here.

I simply use VLC to edit meta data.

Right click on the title, then click on “Information”

Edit your Meta Data, then click “Save Metadata”

Works great for single files, not so great for batch jobs.
Notice at the bottom of the second image that this was on a .ogg file.

Pudge

@Nocturn_Adrift
Is this any use to you? It’s in the AUR.

https://kid3.kde.org/

No, I tried it already. Same situation. As I said, it happens with literally every audio tagger I download.

Strange - I use kid3-qt, and I have no problems with .ogg files (or any other types) and it is very easy to tag or otherwise tweak them. You don’t mention what setup you run, so I have no idea if it might have some effect on things. I’m on XFCE, btw…

My window manager is dwm, but I am not sure how a desktop environment would affect encoding a certain type of audio file.

  • Neither am I - unless some mime-type is undefined…

Perhaps another look at kid3-qt is warranted, in case there is a difference because of the version. I am using the Kraft Dinner method of troubleshooting here (throw against the wall, and see what sticks).

I use Musicbrainz Picard for tagging & auto-tagging, it also supports OGG files.

Just in case, do you have those?

libogg
lib32-libogg