Unable to set Profile picture in EOS KDE DE

I cannot set a profile picture in EOS KDE Atlantis Neo. Attached Screenshot for reference.

Steps to reproduce:
Settings > Users > Click on profile pic > Select pic > Click Apply > Shows error message > Could not get permission to save user {UserName}

This was not happening last week. I did a fresh install and then this is happening. I tried both Erase all data and manual partition.

I am not able to get that pop up which asks for admin password upon changing User details/ profile pic.
Please help.
Kindly let me know what data do you need.

Below is my current spec accourding to neofetch:

                                           OS: EndeavourOS Linux x86_64 
               `:+sssssssssso/.            Host: ASUS TUF Gaming A17 FA706IH_FA706IH 1.0 
             `-/ossssssssssssso/.          Kernel: 5.16.3-arch1-1 
           `-/+sssssssssssssssso+:`        Uptime: 34 mins 
         `-:/+sssssssssssssssssso+/.       Packages: 1095 (pacman) 
       `.://osssssssssssssssssssso++-      Shell: zsh 5.8 
      .://+ssssssssssssssssssssssso++:     Resolution: 1920x1080, 1920x1080 
    .:///ossssssssssssssssssssssssso++:    DE: Plasma 5.23.5 
  `:////ssssssssssssssssssssssssssso+++.   WM: KWin 
`-////+ssssssssssssssssssssssssssso++++-   Theme: Breeze Light [Plasma], Breeze [GTK2/3] 
 `..-+oosssssssssssssssssssssssso+++++/`   Icons: [Plasma], candy-icons [GTK2/3] 
   ./++++++++++++++++++++++++++++++/:.     Terminal: konsole 
  `:::::::::::::::::::::::::------``       CPU: AMD Ryzen 5 4600H with Radeon Graphics (12) @ 3.000GHz 
                                           GPU: AMD ATI 05:00.0 Renoir 
                                           GPU: NVIDIA 01:00.0 NVIDIA Corporation TU117M 
                                           Memory: 2961MiB / 15479MiB

This is being reported in multiple places by multiple people on Arch-based distros.

What version of the accountsservice package do you have installed?

pacman -Q | grep accountsservice 

No issue here, I only just reinstalled a few days ago too, I’ll see if I can change it and get beak t you

Same issue here

Did you fix the permissions to match the package?

EDIT: nvm, I just tested that, it didn’t help.

I have set it the way I’ve always set it and given correct permissions, I’m thinking it might be to do with the last update I did as I only set my profile picture on the laptop a few days ago

pacman -Q | grep accountsservice
accountsservice 22.04.62-2

Same results here
If I can be frank I am not too worried about this and would expect it to be fixed soon

1 Like

Yeah, it seems like a bug in the latest accountsservice package. Downgrading the package and rebooting resolves the issue.


Thanks Dalto, downgrading works. Hoping this would be fixed in the latest version soon. :upside_down_face:

sudo chmod 775 /var/lib/AccountsService/



That seems unrelated to me. At least in my testing, changing the permissions had no effect on the issue either way.


Welcome to EnOS’ forum @Celestial_96 !

Enjoy your interstellar journey onboard Endeavour!

:rocket: :milky_way:


Hi archbtw, I checked the existing permission on my EOS-KDE and it is already 775.

stat -c %a /var/lib/AccountsService/

Thanks for the response though. This is my 1st post in EOS forum and I was amazed to get responses from many. Thank you all.


I also tried what @dalto said and i still can’t set the profile pic on KDE either.

1 Like

If you mean downgrading, did you downgrade far enough and did you restart?

No i didn’t downgrade? I used the change permissions command you had posted above.

Edit: Okay i downgraded the package and it seems really old in number? Version : 0.6.55-3

I didn’t post that command. I said that command wouldn’t help in this situation. :wink:

Well okay … i misunderstood. I downgraded but the accountsservice package seems old in version but it was the only one i had in the cache?