Unable to install EndevourOS - on a USB stick

Hi everyone,
I hope you can give me some help since I cannot go further with my attempt to install EndevourOs on a usb-pendrive (proper install - I want a portable system).
Let me first tell recapitulate my hardware and procedure

usb live: created with rufus (partition scheme, mbr) and etcher portable
target usb: Kingston Datatraveler. I tried on different ones, new and fast new, of every size.

Calamares install: both methods . I would like to install mate, which I prefer as compared to xfce since it support better compiz and it is a more complete desktop. Anyway, I tried also the offline mode

partitioning: automatic and manual (partition scheme: gpt, sdx1: fat32, 300 Mb, flag: boot, esp with gparted, mount point: /boot/efi; sdx2, ext4, mount point “/”

attemp made on acer travelmate p236 in legacy mode, obviously no secure boot: 8gb ram, i5 5th generation processor (6-7 years old, but not so bad actually), ethernet super fast connection , ping 8.8.8.8 gives normal reply and I can surf the internet with firefox without problem; usb live of endeavourOs runs smooth and fast (that’s why I would like to install it!)

I have read the wiki. I know that calamares has a bug. I could follow the installation through the following command

tail -f /home/liveuser/endeavour-install.log

Every attempt to install the system failed. The last one took more than 12 hours (!) and it was not finished. For the last hour I could only see images as event in the log. I was not registered yet so I did not save the log. 
The same procedure in the case of manjaro took about half an hour and was successfully completed. I can run the whole Manjaro system from a pendrive, but it is a xfce and I would like to give EndevourOs with mate desktop again a try.
Could you please give me further advice?
Thank you very much for your attention and care

hello the ISO is from which month

I’m a bit lost. If it’d succeeded on Manjaro, it should’ve been successful in enos too. And on top of that, I’ll need some exact errors. I mean the install is failing, what calamares is showing? What’s its exact behaviour? Is the disk getting mounted? Is the disk getting populated? The only way to be more helpful, is to advice you to go through with the install again, and record these specific behaviours.

Hi,
the iso is the 2019.12.22-x86_64. I forgot to tell that I could not verify it yet since I have on windows only winmd5free and md5 & Sha utility. From both I get the value: 824c4dcc70065cf74dfb7b71cb500906. Could you please tell me if it correct?
Thanks in advance

Calamares shows 53% for hours and it remains stuck with no further error advice. I will try again, this time I will try to do the whole process starting from manjaro, including the download of the iso, which I have done always from win10. Any suggestions for verifying the iso from linux? Is it ok preparing the usb via gparted or should I low format it and then create new partition table?

it’s an hdd or ssd, it all depends on your connection

Sorry, maybe I was not clear enough. I have a ethernet superfast connection. I use a usb live created with etcher (and rufus) to install the system on a usb target drive. No installation on hdd or sdd.

you have that pc on w10

Yes. I am trying now the whole process via manjaro installed on a 64Gb usb. Probably there is a problem with the iso (or the download). This is what I get from the terminal
[sg@sg-pc Scaricati]$ md5sum -c endeavouros-2019.12.22-x86_64.iso.md5sum
endeavouros-2019.12.22-x86_64.iso: NON RIUSCITO
md5sum: ATTENZIONE: 1 codice di controllo calcolato NON corrisponde
[sg@sg-pc Scaricati]$ gpg --recv CB23504F
gpg: keybox ‘/home/sg/.gnupg/pubring.kbx’ created
gpg: key 003DB8B0CB23504F: 2 signatures not checked due to missing keys
gpg: /home/sg/.gnupg/trustdb.gpg: creato il trustdb
gpg: key 003DB8B0CB23504F: public key “EndeavourOS (mailto:info@endeavouros.com)>” imported
gpg: non è stata trovata alcuna chiave definitivamente affidabile
gpg: Numero totale esaminato: 1
gpg: importate: 1
[sg@sg-pc Scaricati]$ gpg --verify endeavouros-2019.12.22-x86_64.iso.sig
gpg: assuming signed data in ‘endeavouros-2019.12.22-x86_64.iso’
gpg: Signature made lun 23 dic 2019, 17:10:52 CET
gpg: using RSA key 497AF50C92AD2384C56E1ACA003DB8B0CB23504F
gpg: issuer “info@endeavouros.com
gpg: BAD signature from “EndeavourOS”
I cannot think that the iso is per se corrupted. Maybe there was a problem with the download or I did something wrong. I would like to try again on Win10. I get via mdr win utilities the value 824c4dcc70065cf74dfb7b71cb500906
Is there a way that I can verify this md5 value. I don’t see it on Eos internet site
Thanks a lot. I come from the debian family and I am new the wordl of arch. Any help would be much appreciated

Can you get this translated?

Recreating the partition table is suggested.

md5sum -c endeavouros-2019.12.22-x86_64.iso.md5sum
endeavouros-2019.12.22-x86_64.iso: FAILED
md5sum: ATTENTION: 1 calculated control code does NOT match

This iso was downloaded by the Alpix mirror. All my copies, actually. I try now from Github and let you know

in torrent

[sg@sg-pc Scaricati]$ md5sum -c endeavouros-2019.12.22-x86_64.iso.md5sum
endeavouros-2019.12.22-x86_64.iso: OK
[sg@sg-pc Scaricati]$ gpg --recv CB23504F
gpg: key 003DB8B0CB23504F: 2 signatures not checked due to missing keys
gpg: key 003DB8B0CB23504F: "EndeavourOS not changed
gpg: Numero totale esaminato: 1
gpg: non modificate: 1
[sg@sg-pc Scaricati]$
[sg@sg-pc Scaricati]$ gpg --verify endeavouros-2019.12.22-x86_64.iso.sig
gpg: assuming signed data in ‘endeavouros-2019.12.22-x86_64.iso’
gpg: Signature made lun 23 dic 2019, 17:10:52 CET
gpg: using RSA key 497AF50C92AD2384C56E1ACA003DB8B0CB23504F
gpg: issuer “info@endeavouros.com
gpg: Good signature from "EndeavourOS
gpg: ATTENZIONE: questa chiave non è certificata con una firma fidata!
gpg: Non ci sono indicazioni che la firma appartenga al proprietario.
Impronta digitale della chiave primaria: 497A F50C 92AD 2384 C56E 1ACA 003D B8B0 CB23 504F
[sg@sg-pc Scaricati]$

Iso from Github seems ok. I proceed.

1 Like

Hope I do not over read something, on my desktop
2019.12.22
dos not boot but on https://endeavour.kamprad.net/beta/ the nvidia version from

https://endeavour.kamprad.net/beta/endeavouros-nvidia-2020.01.12-x86_64.iso

work.
Maybe you can use this one?
We do not know your GPU?

1 Like

Hi,
thanks. I am trying to install now the iso downloaded from Github. This is verified, the other ones (downloaded via Alpix since I am in Europe) got a an error. Maybe this was the problem. I downloaded all my isos from Alpix. I will try and let you know. By the way, any tools on arch for collecting data about hardware? otherwise I should try with cpu-z via win10. Last release of Manjaro xfce works, anyway

I know only inxi :slight_smile:

inxi -Fxxxca --no-host
1 Like

Update
I started the automatic installation 1 h ago. Mate desktop with no nvidia drivers (maybe an error). The calamares installer says 59%. Last message, however, from the terminal came two minutes ago
18:56:15 [6]: Running “chroot” ("/tmp/calamares-root-hk3ek_fw", “pacman”, “-S”, “–noconfirm”, “gvfs-mtp”)
Anyway, thank to your help I could read the specs of my hardware:
liveuser@archiso ~]$ inxi -Fxxxca --no-host
System:
Kernel: 5.4.6-arch1-1 x86_64 bits: 64 compiler: gcc v: 9.2.0
parameters: initrd=\EFI\archiso\intel_ucode.img
initrd=\EFI\archiso\amd_ucode.img initrd=\EFI\archiso\archiso.img
archisobasedir=arch cow_spacesize=10G archisolabel=ENDEAVOUROS
Desktop: Xfce 4.14.1 tk: Gtk 3.24.10 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: EndeavourOS
Machine:
Type: Laptop System: Acer product: TravelMate P236-M v: V1.22
serial:
Mobo: Acer model: TravelMate P236-M v: V1.22 serial:
UEFI: Insyde v: 1.22 date: 06/28/2016

Graphics:
Device-1: Intel HD Graphics 5500 vendor: Acer Incorporated ALI
driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1616
Display: server: X.Org 1.20.6 driver: i915 compositor: xcompmgr
resolution: 1366x768~60Hz

Did you check the option to encrypt the disk in Calamares? That may cause a problem.

2 Likes