Unable to change some settings in KDE Plasma

Hi All.
It is not possible to change the touch-pad’s scrolling direction, neither is it possible to turn the screensaver off. Despite being turned off in the Energy Saving settings, it keep appearing after some minutes of inactivity.

Is it possible to fix these problems?

Plasma System Settings are notoriously difficult to navigate. The devs are aware of the issue, and they change the settings layout with almost every new release. This only worsens the problem. :rofl:

Nevertheless, Plasma is great! You’ll get used to its quirks in time. :smiley:

Regarding scrolling

Go to:

System Settings → Input Devices → Touchpad → Scrolling (tab)

and there you have “Reverse scrolling” two checkboxes, one for horizontal, one for vertical.

Regarding automatic screen locking

Go to:

Workspace Behaviour → Screen Locking

and uncheck “Lock screen automatically”.

Welcome to the forum. :partying_face:


Welcome aboard! :partying_face:

You might have to create:

cat /etc/X11/xorg.conf.d/30-touchpad.conf
Section "InputClass"
Identifier "touchpad"
Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
    Option "NaturalScrolling" "off"

Only an example.

Thank you for the welcoming!
Now that I tried changing the scrolling direction again, the change stuck and reversing the scolling direction now works as it should. Thank you for the tip!

1 Like

There’s dozens of us who put up with KDE’s quirks - DOZENS. (Actually, I’d dare say it’s the most common DE here).

Welcome to the forum!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.