Unable to boot with with a gui

When i try to boot into endeavour after install i get sendt into an arch Linux terminal like the one on the picture below. Am i doing something wrong or is it supposed to be like that? I’m on a dual boot if that is to any help.

image

1 Like

Are you sure you installed a Desktop Environment?
https://endeavouros.com/docs/installation/calamares-offline-installer-tips/

Oh… how do I do that?

Welcome to the community.

You most probably forgot to select a DE during install, you just chosen the Base install. This is why you have this screen.

1 Like

Oh ok. Thx a lot!!

You don’t have to re-install your system in order to do that. You can install a DE from a tty at any time if you have network connection.
https://endeavouros.com/docs/pacman/how-to-install-desktop-environments-offline-install-users/

You will also need a Display Manager which will allow you to choose the installed DE at boot. I’d recommend lightDM since it’s cross-desktop.

To install it just type into the tty:
sudo pacman -S lightdm lightdm-gtk-greeter lightdm-gtk-greeter-settings

And enable it with
sudo systemctl enable lightdm.service

2 Likes

I’m not completely sure if that works, you can try, since we haven’t optimised a pure Base install in the December release, but you can try.

Re-install using the offline installer. It won’t take long and fits in better with your early stage of arch linux use.

I reinstalled it and it works fine now. thanks for all help!!

5 Likes

You saved me two hours of searching for mistakes. :grin: I just trained on how to install EOS via CLI and I never got a Display Manager popping up during bootup, so I always thought there were some packages missing…

Simply enabling the Display Manager brought the solution! :sweat_smile: Thank you!

1 Like