Can't get GUI to boot

So I’m definitely versed in computers but new to Linux overall. My friend suggested this OS for my server and I went with it. We installed the GUI from the beginning, but SSH’ed into it which I admit made no sense and we should have just done the plain command line but it came in handy.

Recently had a power surge that my surge protector didn’t protect against for some reason, thinking my power strip may have been old enough that it didn’t work. My main desktop’s PSU is broke so I decided to switch to my server as it had the GUI and I’ve been thinking about switching to Linux all together since Windows has been crashing on me as of late.

I’ve been fiddling with it for a few days here and I was trying to get steam installed. My graphics card is apparently an Nvidia which I’ve been told can be finicky with most Linux distros, especially Arch. I was able to get it installed to where it wasn’t crashing my computer but it just wouldn’t open as I was trying to install a more proper driver and I don’t remember if it succeeded as this was yesterday. Another page said to restart and I went ahead and did that and now it won’t properly boot and gets stuck at Started Network Manager Script Dispatcher Service. Because of my main desktop breaking, I was hoping to grab the files off my hard drive in that computer so I added the hard drive to the server but of course that was a whole nutcase in itself as I couldn’t mount it but it’s still in the computer. The reason why I mention those things is I don’t know if those could influence the issue that I am having.

This person in this form just didn’t install the GUI but had his computer stop at a similar point as I was able to get into a command line interface but I couldn’t think of much I could do.

Anyone got any ideas?

Welcome to the forum!

To get help with your issue, start by providing relevant logs and, most importantly, hardware data.

See this for more info:

Keep in mind that you’re likely to have a tougher time on Linux than a complete newbie, due to your preconceptions about how things ought to be. They are very different on Linux from windoze. Unlearning windoze is the toughest part of becoming proficient at Linux.

1 Like

First of all welcome @sonicobsesinter to the wonderful world of EndeavourOS.
I understand from above line that it worked fine for a few days.
When installing, which boot loader did you select? systemd-boot or Grub? Do you have BTRFS, snapshots of system?

We used all default install options

I guess you installed from a USB flash disk (or whatever).
I hope you can boot from it. Have you tried to boot from it? Do you have any data on the drive that you really need?
I am not expert by the way, I am just trying to find out if there is anything I can help with.

That’s why I gave you that link above. There you can find a command that will print your hardware info. This info is useful to anyone trying to help you.


I have no idea here what you are trying to do? Are you installing EndeavourOS without a desktop? When you create a live usb and boot from it the installer can install online various desktops or without a desktop. It also has an offline install which is xfce desktop and there are a number of community editions. Installing nvidia drivers would be done automatically if selecting nvidia in the menu when booting the live ISO if the graphics card is current and is supported by the latest drivers. Otherwise if you select the default menu option it would install nouveau open source drivers if you have nvidia.

Edit: Start with providing the hardware log and a better explanation of what you are trying to achieve.

My apologies for the lack of context. I got a bit frustrated and had to take a break completely unrelated to you people this fourm.

It was all set up and working and all of a sudden it just won’t boot properly and gets stuck at certain places in the boot process. I was able to get it into a CLI but I havent been able to figure out how to get it back into the GUI. In the main post I was just saying I was in the middle of a few things because I couldn’t get something working so I’d move onto the next thing so I was in the middle of a few things. I was working on getting steam installed and running and it wouldn’t open at all whereas the last time it just froze the whole system so I rebooted as now as I said it won’t boot fully. I have a second drive from my other computer with Windows on it so I’m not sure if it’s just not liking that but to my knowlage all I can think of is it just couldn’t boot off of it which was not my goal but I’m not sure if that would have complicated things when the computer was trying to choose a boot drive and all of a sudden there was a second drive and it boot into grub and got confused.

I’m guessing here this is also an issue with me being new to this fourm thing and not knowing what I am supposed to provide so I’m sorry about that. The computer is prebuilt so I don’t know the specific specs off hand and the language used when I use lspci doesn’t make 100% sense to me.

This was what I was able to make out (I do build things and know how hardware specs work it just didn’t all make sense what it spit out in the CLI to me)
Intel Xeon V3 core i7
NVIDIA Corp GF199 [NVS 310] (rev a1)

I have some things I would rather have especially in the realm of it was in the GUI for a few days working correctly and I was getting things installed it just won’t return to it after a few things I was doing and I’m just trying to get down to the cause. I don’t have the original boot media but have a laptop if that’s something I’d need to do.

The Nvidia card you have is supported by legacy drivers 340xx version. Are you able to get into a TTY and log in?

Edit: If you can get into terminal and run this and post the output.

inxi -Fz

Can you open the link I posted all the way above? It literally tells you what you need to provide, it’s under the heading “Hardware information”, that inxi command. Just run it in the terminal (in the TTY) and post the output here. If you are unwilling to even follow such a simple guide, how do you expect to get help? :man_facepalming:

I see, you installed and “played” with the system till it got broken!
This is normal, I did it many times. But this indicates you are eager to learn and curious.
You may try from the prompt the following command


Maybe posting the output of the command would help.
This command simply runs the desktop environment. (as I said I am no expert, but I know a little). Maybe while you were “playing” with the system you made something that caused the desktop environment not to launch. What was your desktop environment?

If you tell us your desktop of choice, in case startx didn’t work, maybe you can try install the desktop you want and see if it goes fine after that. I assume you somehow broke your desktop while playing with the system, so reinstalling it might help.

I will put myself in your place, if I were you I would download the latest ISO, run the dd command to install it to a USB flash disk and reinstall.
During installation I would be sure to follow the defaults, and be sure to chose KDE Plasma as my desktop environment (my personal preference), but it is up to you to chose whatever you like. Then when it comes to selecting the boot loader I would be sure it is systemd-boot not Grub and carry on with the installation. So, simply follow the defaults, the only option you have to chose would be the desktop environment.

I would as well chose BTRFS file system to start with, but this is another story, (why, and its benefits, how-to… etc.), simply BTRFS file system allows you to have snapshots of your operating system you can revert to an earlier working snapshot. This is another story as I mentioned.

Was trying to think of a way to get the output posted here and then realized I could just take a picture.

I have tried the startx command and it says that it’s unable to do so.

I may try reinstalling if absolutely necessary.

Realized there is a command to show everything line by line. | (Pipe)

It looks like there is no GPU driver in use. Try to install it from the TTY.

yay nvidia-390xx-dkms

That’s what I thought was happening so I was trying to find the command to do so, thank you.

Tried it and I’m a bit confused on what it’s asking me to do

It’s letting you know there is more than one package available to install for that driver. You should go with option 1 by simply typing the number 1 and hitting enter.

I’m just thinking if I were in your place I would do:

  • Copy any data I need to an external drive
  • make another fresh install

(I just made a fresh install a few days ago, so there is nothing much I would lose). I just give priority to saving time and effort compare to what I would lose doing a fresh install.

I would be sure to follow defaults as mentioned in a previous post)

Just press enter to select the default.

It outputs “there is nothing to do”