Unable to boot after installing new sound card AE-7

Hi everyone,

Love Endeavour OS as I’ve been using it for a few weeks now but lately I’ve decided to upgrade my soundcard. Everything was working fine with my AE-5 before but as soon as I install my new AE-7 I’m unable to boot into EOS. This applies to the live disk usb drive as well. Even tried ubuntu live disk and still does not boot. There is something happening with that particular sound card and linux. Wondering if anyone has any idea on a workaround or fix. I`ve been googling for a while now and it seems that the AE-7 is supported in the latest kernels. Windows does not have any issues with it.


Hardware is as following :

AMD Ryzen 7950x
ASUS X670E Pro Art Creator Wifi (BIOS 1202)
GSkillz 64 GB DDR 6000
Asus rog strix 3090 Gaming OC 24G
2 TB Samsung 990 PRO (windows)
1 TB Samsung 990 PRO (EOS)
4 TB Sabrent Rocket 4 plus (Games)
Soundblaster AE-7

here are some screen capture of the errors at boot. Does not go all the way to desktop and eventually does boot loop.

if you take a look at the screenshot you can see that there is an error about snd_hda_intel which is an intel sound card which I don’t have. (nvidia HDA ?) My onboard soundcard is disabled. I’ve even tried disabling the onboard video card but the error is still there. Also tried to disable acpi power mode in the modprobe.d folder but this error still happens. I`ve seen one other post on reddit with a user that has this issue but he ended up trading is AE-7 for an AE-5.

In the end if I reinstall my AE-5 I can go back to the desktop but I would rather use the AE-7 as the sound quality is much better.

Any help would be appreciated.


Not related to the problem you are facing but…
This BIOS and RAM you are using, 6000MHz with AMD EXPO enabled is not safe.

I suggest you update the BIOS as soon as you can.
Obs: this problem is not affecting only x3d chips.

More info:

Thank i’ve already limited my SoC voltage to 1.25v manually. Probes give me around 1.28v. Latest bios are only beta at the moment. I’ve been following for a while.

1 Like

I see there are only 2 Pci-e 16X slots and One Pci-e 16x slot that supports x2 mode? There may be some hardware conflict on Linux. :thinking:

1 x PCIe 4.0 x16 slot (supports x2 mode)**
* Please check the PCIe bifurcation table in support site (https://www.asus.com/support/FAQ/1037507/).
** PCIEX16_3 shares bandwidth with M.2_3 slot. Please adjust in BIOS setting to enable PCIEX16_3.
- To ensure compatibility of the device installed, please refer to https://www.asus.com/support/ for the list of supported peripherals.

Edit: Do you disable the onboard sound when adding the card?

The 2nd PCIe slot is empty as it shares the bandwidth with video card. So it’s either

16x 0x 4x
8x 8x 4x
or the last 4x is 2x if the M2_3 slot is populated which is not.

The sound card is on the 3rd PCIe slot so I can get the full 16x for the video card. It should technically get the full 4x bandwidth for itself. I’ll check again to make sure my M2_3 is not populated but I distinctively remember not adding a M2 to it to make sure it does not share it’s bandwidth.

Onboard sound card is always disabled. I never use it. Can’t get 5.1 on it unless I plug the 3 analog cables. One of which must be plugged on the front panel audio I have a corsair 1000D to achieve 5.1. This has not been thought for large cases…

I thought the onboard has 7.1 audio?

It’s technically possible. Although the setup for it is really stupid. it’s not technically a gaming board. So someone at Asus found that logical that one should plug the front speakers on the front of the case. I got a Corsair 1000D can’t do that…

Have you looked at this setting in Bios? Because in the log XHCI_hcd is failing on boot.

XHCI Hand-off
This is a workaround for OSes without XHCI hand-off support. The XHCI ownership change
should be claimed by XHCI driver.
[Disabled] Support XHCI by XHCI drivers for operating systems with XHCI support.
[Enabled] Support XHCI by BIOS for operating systems without XHCI support

No joy there. it’s already enabled by default. I did try disabling it but still get stuck at the same spot. It get stuck at gspca_vc032x: reg_r err -32 for a while (few minutes) then it gives this error message :

It may be missing the kernel source code info for that card? It was supposed to be added?

SND_PCI_QUIRK(0x1102, 0x0081, "Sound Blaster AE-7", QUIRK_AE7)



it’s odd I could try applying the patch to the kernel see if that does anything. I’ll remove the card and try to see if the patch is already applied to the kernel. If not i’ll try to apply it. it’s kinda old though. I would believe it’s already applied in there…

It should be applied but maybe there is some hardware conflict in some alsa file or pipewire?

Edit: Problem with sound issues is there are so many things involved to try and figure out what the issue is caused by. Makes it hard when it won’t even boot on it.

Chances are I hit the perfect storm of hardware that triggers some kind of incompatibility with that particular card. Maybe something will be fixed at some point in time with the kernel or alsa or my motherboard bios. I can boot EOS just not with the card plugged in.

Thanks for the help by the way really appreciated.

I just tried the 6.3-next kernel. Error is somewhat different but related to the xHCI host. There is definitely something there.

It may be assigning the wrong id number?

From the Sound Blaster support site.

Does the Sound Blaster AE-7 work in Linux?
Creative does not provide an official (thus does not directly support) Linux driver, however, there are development efforts in the ALSA community to support SoundCore 3D based Creative sound cards. Users may wish to contact ALSA community for the drivers. There is also a discussion thread from developers on the Official Sound Blaster Subreddit.

I know that creative itself does not support linux. They don’t do drivers but the community has been good at reverse engineering the drivers for a bunch of creative card. According to this 2020 articles the AE-7 should be supported in the kernel. https://www.phoronix.com/news/SoundBlaster-AE-7-Linux

There is this as well. Alsa supposedly support the AE-7 : https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/log/?qt=grep&q=ae-7

If it’s not booting though i would think that there is some hardware conflict maybe Bios related on your particular board. :thinking: I guess you could always try the latest Beta Bios for your board. Then when the final comes out you can update it again if it’s a different version number. Sometimes they keep the same version number if there are no changes from the Beta. Other times they have a new version number and you would have to update it again.

I’ll try the latest beta to see what happens. At this point i’ve even tried unplugging every usb device except keyboard and mouse. It’s most likely a hardware conflict. I’ll reset bios to factory and try to boot and then i’ll flash the bios. With luck i’ll be able to boot but I don’t have a lot of hope.

Yeah no joy there either. Still hangs at the same spot. Maybe sometime in the future there will be a bios release or a kernel update that fixes this issue.

1 Like