Turning off the pc does not work

I have installed on the pc-desktop EOS with XFCE and EOS theme and does not let me turn off the pc, I can reboot without problems, but I can not get it to shut down, both from panel and terminal, I’ve tried everything, also m does it with all the kernels installed.

This pulls in when trying to switch off:

Thank you as always.

1 Like

Hi old friend…Seems to be an issue perhaps with video drivers…

sd-umount: failed to unmount /oldroot Device or resource busy · Issue #21465 · systemd/systemd · GitHub

Some are suggesting systemd but others are saying driver issue.

More:

shutdown[1]: Failed to wait for process: Protocol error · Issue #8155 · systemd/systemd · GitHub

2 Likes

@Elloquin it’s a pleasure to read you, thanks for the link and I will wait, before I touch anything, for a new update.
I’ll keep my eyes open.

1 Like

It would help if you post your system info.
Do you have nvidia card and use proprietary driver? If so, try nouveau to see if it works properly.

1 Like
$ pacman -Qs nvidia
local/egl-wayland 2:1.1.9+r3+g582b2d3-1
    EGLStream-based Wayland external platform
local/libvdpau 1.4-1
    Nvidia VDPAU library
local/libxnvctrl 495.44-1
    NVIDIA NV-CONTROL X extension
local/nvidia-dkms 495.44-6
    NVIDIA drivers - module sources
local/nvidia-installer-db 2.5.1-2
    Database for the script to setup nvidia drivers in EndeavourOS
local/nvidia-installer-dkms 3.3.11-1
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-settings 495.44-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 495.44-6
    NVIDIA drivers utilities

It seems you use proprietary nvidia drivers.

To check if the issue is related with nvidia driver, change to nouveau, using nvidia-installer-dkms utility.

nvidia-installer-dkms -h (shows help)

nvidia-installer-dkms -n (--nouveau) (Restores nouveau (open) nvidia driver)
1 Like

Maybe this is same issue? Post 20 after you check. This is a bit dated!

1 Like

@Resiliencia
Any luck with the shutdown?

1 Like

Hello !
No it didn’t work adding shutdown to /etc/mkinitcpio.conf.

It happens that it gets totally stuck and not for a few minutes …then I have to turn it off hard, I can’t even reboot with the reset.

Hello !

I still can’t turn off my computer in the conventional way.

Any news on this matter ?

Thank you.

Well hello there stranger. Sorry to hear you still have this issue. Hope you are doing well? Wish i had an answer to help with that.

2 Likes

Hi Rick !

I keep asking, as I don’t feel like reinstalling, moreover with 2 laptops with Intel I don’t have this problem, I would think that the problem is Nvidia, I don’t know …

I feel fine, I hope you do too !

Doing well under the circumstances that we all have to contend with. THis is on your desktop computer with Nvidia? Is it installed and set up with hibernation?

Edit: Any message on the screen on shutdown?

1 Like

Yesss

No

inxi -Ga
cat /etc/default/grub | eos-sendlog
cat /etc/mkinitcpio.conf | eos-sendlog

Do you have this xorg file? /etc/X11/xorg.conf.d/20-nvidia.conf

1 Like

Do you have an integrated GPU on the machine that you could use instead of Nvidia?
Maybe that way could be possible to limit the problem to nvidia?

That would mean blacklisting nvidia and using the Intel driver.

1 Like
$ inxi -Ga
Graphics:
  Device-1: NVIDIA TU117 [GeForce GTX 1650] vendor: Gigabyte driver: nvidia
    v: 495.46 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f82
    class-ID: 0300
  Display: x11 server: X.Org 1.21.1.3 compositor: xfwm4 v: 4.16.1 driver:
    loaded: nvidia unloaded: fbdev,modesetting,vesa alternate: nouveau,nv
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3")
    s-diag: 583mm (23")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102
    size: 480x270mm (18.9x10.6") diag: 551mm (21.7")
  Message: Unable to show advanced data. Required tool glxinfo missing.

https://clbin.com/XpUSE

https://clbin.com/X4RN6

$ cat /etc/X11/xorg.conf.d/20-nvidia.conf
cat: /etc/X11/xorg.conf.d/20-nvidia.conf: No existe el fichero o el directorio

https://imgur.com/ps2cFnn.png → I did it and it didn’t work, but the shots may come that way as well as this way: → https://imgur.com/GxHtOyQ.png

I have the i5-9400 graphics card, but it doesn’t seem …

And the nouveau driver instead of nvidia?

1 Like

Yeah sure, I could do that … but I really intend to make it work with nvidia. :man_shrugging: