Trying to add desktop icons to Budgie

Hey guys, Im trying to figure out how to add Desktop icons to Budgie, I came across a post earlier discussing it but it required nautilus-legacy, which for some reason will not compile anymore.

I keep getting this error when I build the package with the AUR

FAILED: nautilus-desktop/nautilus-desktop 
cc  -o nautilus-desktop/nautilus-desktop nautilus-desktop/nautilus-desktop.p/meson-generated_.._.._src_nautilus-freedesktop-generated.c.o nautilus-desktop/nautilus-desktop.p/main-desktop.c.o nautilus-desktop/nautilus-desktop.p/nautilus-desktop-application.c.o nautilus-desktop/nautilus-desktop.p/nautilus-desktop-canvas-view.c.o nautilus-desktop/nautilus-desktop.p/nautilus-desktop-canvas-view-container.c.o nautilus-desktop/nautilus-desktop.p/nautilus-desktop-directory.c.o nautilus-desktop/nautilus-desktop.p/nautilus-desktop-directory-file.c.o nautilus-desktop/nautilus-desktop.p/nautilus-desktop-icon-file.c.o nautilus-desktop/nautilus-desktop.p/nautilus-desktop-link.c.o nautilus-desktop/nautilus-desktop.p/nautilus-desktop-link-monitor.c.o nautilus-desktop/nautilus-desktop.p/nautilus-desktop-metadata.c.o nautilus-desktop/nautilus-desktop.p/nautilus-desktop-window.c.o nautilus-desktop/nautilus-desktop.p/nautilus-desktop-window-slot.c.o -flto -Wl,--as-needed -Wl,--no-undefined -pie -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,--start-group src/libnautilus.a subprojects/libgd/libgd/libgd.a eel/libeel-2.a libnautilus-extension/libnautilus-extension.so.1.4.0 /usr/lib/libglib-2.0.so /usr/lib/libgtk-3.so /usr/lib/libgdk-3.so /usr/lib/libz.so /usr/lib/libpangocairo-1.0.so /usr/lib/libpango-1.0.so /usr/lib/libharfbuzz.so /usr/lib/libatk-1.0.so /usr/lib/libcairo-gobject.so /usr/lib/libcairo.so /usr/lib/libgdk_pixbuf-2.0.so /usr/lib/libgio-2.0.so /usr/lib/libgobject-2.0.so /usr/lib/libgnome-autoar-0.so /usr/lib/libarchive.so /usr/lib/libxml2.so /usr/lib/libgailutil-3.so /usr/lib/libgnome-desktop-3.so /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/../../../../lib/libm.so /usr/lib/libX11.so /usr/lib/libgmodule-2.0.so -pthread /usr/lib/libtracker-sparql-2.0.so -Wl,--export-dynamic /usr/lib/libexif.so /usr/lib/libexempi.so -lm -Wl,--end-group '-Wl,-rpath,$ORIGIN/../libnautilus-extension' -Wl,-rpath-link,/var/tmp/pamac-build-novaviper/nautilus-legacy/src/build/libnautilus-extension
/usr/bin/ld: /tmp/nautilus-desktop.oNpx6o.ltrans0.ltrans.o: in function `background_changed':
<artificial>:(.text+0x104a): undefined reference to `gnome_bg_get_surface_from_root'

Is there anyway to get desktop icons without nautlius-legacy?

Will not build for me either (Plasma).

you can try to check : https://bbs.archlinux.org/viewtopic.php?id=241674

using nemo ?

1 Like

I haven’t tried Nemo before

is a nautilus fork with desktop n but need a hack offcourse :slight_smile:

1 Like

Interesting, I just got it downloaded but uh… how do I make it the default file explorer in Budgie?

must install budgie first got bits and pieces but can’t tell for now :slight_smile:

I have budgie already installed and all

me not have to try that hack :slight_smile: it is possible but cannot tel exact

It doesn’t seem to be working because I don’t have that budgie-handler thing and it stil doesn’t appear in the tweaks or in the settings. Im wondering if it got removed in Gnome 3.38

installing budgie in vm :slight_smile: but try to workout the theory, nemo is theoretical stil a nautilus-legacy, lets say, ikey in the first period of solusos on debian worked nautilus and called it altena or something and guys of mind forked that from solusos lol

That was my first issue with bugie, and my first post on this forum

The easiest way is this

Worked for me.

Laters

Edit: You can keep whatever version of nautilus you got on install, in fact, I just used it last week, when I did some desktophopping … again :sweat_smile: :rofl:

1 Like

ah wel did the stuf , and budgie-handler is there but you ignore it, furter put the nemo-autorun blabla in ~/.config/aurostart/ and changed as on the arch site it auto startS…

this

and https://bbs.archlinux.org/viewtopic.php?pid=1840628#p1840628

should work and i had nautilus removed also :slight_smile: pacman -R nautilus…

the icons starts with nemo-desktop and in applications name decapriated but in application should call nemo-autorun-software.desktop , i copied and editted a bit as in the arch site and set in the desktop to nemo-desktop as called and added one line

should work nemo

budgie-handler is something of budgie internal working the gsetting is set to ignore if there is some error… but nemo-desktop should work

@Daemonicvs’ solution worked, thanks!

2 Likes