Issues with Budgie

Hi there,

So, I was curious to try Solus + Budgie, I installed on an older-almost-dead laptop, and I really liked Budgie; then I re-installed Endeavour + Budgie.

And I am missing a bunch of settings and configs that were in budgie from solus.

Mainly I am not able to create links to folders nor programs on the desktop, the section for ‘desktop icons’ is missing in ‘budgie desktop settings’; and some other oddities here and there.

I want to clarify that I am not complaining nor ranting, but It I feel is a weird thing, because I notice that, on solus, budgie an gnome are separated, each has its own settings, some of them not even compatible. As if they made a point to say they are not the same. Which makes sense, since they made budgie.

On endeavour, I got budgie, but I got the exact settings and configs from gnome, as if budgie is just a skin for gnome.

My guess is I made a silly when installed online.

Does anyone else who’s using budgie got the same?, should I reinstall in a different way? I hope no ones feels aggravated at this, that is not my intend.

Tnx.

Looking at budgie-desktop package page:

Do you have install some of them? Try also to install budgie-extras.

I think it’ll help a little here.

2 Likes

Yeah, I got all those and helped with some of the stuff, I still have not find a way to get links on the desktop, but found a widget “places” to set at the top bar, so I can manage. It is getting there.

Tnx.

Follow these steps to enable Desktop icons for Budgie:

Go to Terminal and paste in:

yay nautilus-legacy (press 1, then y)

Then execute this command:
sudo pacman -Syu exempi gnome-autoar gnome-desktop gvfs libexif libnautilus-extension nautilus-sendto tracker git gobject-introspection gtk-doc meson packagekit (yes)

sudo ln -s /usr/lib/gnome-desktop-3.so /usr/libgnome-desktop-3.so.17

yay gnome-tweaks(press 1, y)

Launch Tweaks. Go to Desktop in Tweaks.
Enable Desktop Icons there on the side.

Restart your computer.

When you drag an application icon onto the desktop you may get asked to trust the application first.

Adapted from: https://forum.manjaro.org/t/guide-enable-desktop-icons-in-budgie-1-8-0-stable-upd-nov-15-help-discussion/111448

Well stuff me with weed and call me molly, That did it. :metal:

Thx.

1 Like

Great…now I can try that as I like the desktop icons also.

1 Like

You can also try https://aur.archlinux.org/packages/desktopfolder for desktop icons if you want to keep the latest nautilus

Thx, I would have tried that, if I did not already made the first choice :joy:

Yeah not many people know about it, but it works very well and looks nicer

I don’t see any desktop in tweaks. Seems to me i tried this before and never got anywhere. Missing something?

I tried it again just now, and it does work, just make sure that you follow the instructions in their exact order. For example, you need nautilus-legacy, which does have to replace the nautilus package in case you already have it installed.

Also, after you’ve done everything as described, you may have to launch Tweaks maybe 2, or 3 times before Desktop shows up in the sidebar:

I 'll try it again on v-box and see if i can get it to work.
Edit: Just tried it and nothing. There is no desktop to enable.

Frustrating when stuff doesn’t work. I get an error building nautilus-legacy right at the end!
Tried it again and still doesn’t work.

1 Like