Troubleshooting in-game graphics problem


I have a problem in the game Star Conflict: black squares appear around the ship that look like exhaust, some kind of graphical element that’s not being rendered properly. It’s totally ruining a game that I love playing. The problem has been reported several times by Linux users to the game maker but nothing’s been done so I am trying to troubleshoot this to see if I can fix it.

Perhaps it’s not a game issue but a Mesa/Steam/Proton problem. The only problem is is that I don’t really know how to go about troubleshooting this. Where is the best place to start? What are the most likely culprits?

I have tried changing/toggling all graphic-related options in-game but nothing has worked.

I’m running a ThinkPad X395 with AMD Ryzen 5 PRO 3500U w/ Radeon Vega Mobile Gfx and
Advanced Micro Devices, Inc. [AMD/ATI] Picasso (rev d2)

Mesa items installed:

mesa 20.2.1-1
lib32-mesa 20.2.1-1
glu 9.0.1-2

Running latest Steam with Proton (5.13-1)

Any help would be much appreciated.


Could be an issue with Mesa, but difficult to tell.
You could try using mesa-git and see if it helps.
If not, you can open an issue on mesa bugtracker, but it’s also possible that it is an issue with Proton and/or the game itself.


Could also be dxvk perhaps try see if it helps to exclude:

btw there is native version, maybe it works better

Looks like Wine/Proton/dxvk type of problem to me, but who knows maybe it’s mesa…

Let’s try to get log:

See below

Actually it’s probably game itself, since this happens also on Linux native version, can’t be coincidence:

Shame on devs :laughing:
Pressure them!

1 Like

Are you running just the amdgpu module for graphics?