Troubleshooting cpufetch-git build

Moderation Note: Moved from Favourite Lesser Known Programs

Haven’t figured out what’s wrong with the install on this - it appears to all be working, but chokes at the end:

==> Creating package "cpufetch-git"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...

zstd: can't stat 8 : No such file or directory -- ignored 
==> ERROR: Failed to create package file.
error making: cpufetch-git

However - it appeared to have made the package successfully despite the message, so I installed the created package with sudo pacman -U, and it appears to work! (right facts and ID of the processor). Very strange…

Works fine here, what are you using to build the package?

1 Like

Worked for me but i used pamac. :laughing:

2 Likes

I wouldn’t try THAT regardless! :grin: Just a normal yay invocation, but something got missed (that I haven’t found yet). As I said, though, it all works fine after hand-installing the package it built…

Try cleanbuilding it.

1 Like

Same error - and same result (package is built OK)… I wonder what I have set wrong on this box! (my oldest EnOS on a Ryzen 5 2400G system).

is this a new install? could it be missing the dev tools required for packing?

How’s your /etc/makepkg.conf?
Have you executed pacdiff (e.g. from Welcome) lately?

I don’t know if this gets us any further - but I was expecting it too! It has been a while on this system since I ran pacdiff - but it turned out NOT to be THAT long…

Ran pacdiff, sorted it all out, but the change to zst had already been integrated…

Problem still continues, build still succeeds anyway…

Oh - and /etc/makepkg.conf looks normal to me… unless adding -T 8 to the compression options causes a problem?? Thought I might as well use all 8 threads of this system for that…

1 Like

download from https://github.com/Dr-Noob/cpufetch
unzip the file
cd cpufetch-master
make
sudo cp cpufetch /usr/local/bin
work fine

It should be -T8 I believe. That is probably your issue.

EDIT: Definitely…

$ zstd -T 8 ./ff.tar 
zstd: can't stat 8 : No such file or directory -- ignored 
1 files compressed : 40.20%  (95580160 => 38419981 bytes)       
               
$ zstd -T8 ./ff.tar 
./ff.tar             : 40.20%   (95580160 => 38419981 bytes, ./ff.tar.zst)
1 Like

OK kids - don’t trust anything but the Archwiki. Someone else’s script added that in ages ago - and it never gave trouble before. But - it WAS the trouble this time… maybe the change to zst differed?

Research is a good idea - no - it’s the law! :grin:

1 Like

The zstd man page does put the number right next to -T, but doesn’t say it must be so.
However, similar options in other tools allow separating the number from the option.

So the option handling in zstd seems slightly different from the general way.
Because of that, looks like the best practice is to follow the manuals to the letter (and then test it). :wink:

The options for each compression method are different. That is why each one has it’s own line in makepkg.conf. Generally speaking, you can’t transfer the options you used with xz to zstd.

1 Like

We all know why you shouldn’t ASSUME - just another place it can get you :grin:

I haven’t propagated the change everywhere yet, but it appears to have been the problem. It is amazing how often shortcuts…aren’t! Now to try it on other builds, because I suspect I did a similar change elsewhere :blush:

1 Like

1 Like