Trouble with wifi

hI all. I’m an Arch user and have 4 thinkpads but I wanted to try this distro. I type in the wifi password and then a new window opens asking for autentication. I tried the same wifi pasw -my password and root password. Nothing works. I cant even update or install. Anyone have a solution

ip link

???

that does only give me wlp3s0 and so on

lspci -k

?

that was a lot of info. not sure how i can use this to get connected though. never had this issue before

In order to help you, we have to have more data about your hardware, specifically your Wi-Fi card. :thinking:

most of the info here is intel
what was weird was that it didnt accept the wifi password. all my other thinkpads works just fine

It seems I cant get access to the mirrors. will duckduckgo and figure it out. Spent more than a day on this now- seriously cosidering installing Arch on this one too.

@judd asked you to post lspci -k This will show what chip your wifi is. I’m pretty sure it is Intel iwlwifi because they seem to be the ones that are problematic. Ip link tells us the name that’s also important. We can’t help without information. So if you could please post the two commands so it can be looked at.

you are correct it is intel iwlwifi when i do lspci-k
iplink is there something special you want there- as i cant use that computer and its way to much to type

edit i have the same on the other thinkpads and they work just fine

You don’t type it you post the output of both. Copy and paste what is in the terminal but put three ``` before. it and after it. Like this:

[rick@archlinux ~]$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether 00:01:29:d7:25:ce brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state DORMANT mode DORMANT group default qlen 1000
    link/ether 5e:ea:48:6c:4b:ea brd ff:ff:ff:ff:ff:ff

I realize you can’t connect so you can’t post it. Sorry…

1 Like

hard to get the output from the computer thats useless over to this one

Ya sorry i wasn’t thinking there. This makes harder. Can you type lspci | grep -i intel
and tell me the digits it gives you at the beginning. It should be something like this: 0c:00.0

I come back to this tomorrow - i dont have a phone here right now. So then I can at least take a photo of the screen. but htere are approx 20-25 lines and they all begin with different numbers

Okay so I am connected to the wifi. I just updated the archlinux-keyring. But nothin else works - so it’s obviously a mirror issue. I get all this couldnt resolve endevouros git etc errors.

Have you tried the command

sudo pacman -Syyu

to refresh the mirrors?

yes it did nothing

edit:
there’s a lot of errors couldnt get the file from multilib.db from mirror xxx could not resolve host xxx
the last 5 lines say could not get file endeavouros.db from sourceforge.net ; could not resolve host sourceforge.net

For checking purposes I’ve updated the system on a running machine, installed EOS in a VM and ran the live environment and in all three situations I couldn’t reproduce the problems you’re encountering.

Try sudo pacman -Syyuu

So it wasn’t the wifi not being connected at all then?

no I was connected. I got confused by the little window asking for password or whatever. But I had no problem installing archlinux-keyring. But that’s about all I can do. I can search for programs but when I try to install them - I get all these errors.