Touchpad right click not working in cinnamon

Hi, can someone help me. The right click of my touchpad is not working. I’ve been messing around with the settings and noting fixes it. I saw a similar post, but that problem was in Gnome and the solution was related with Gnome tweak tools.

I just solved by installing the following package xf86-input-synaptics. I discover that on this post

Just to mention, in case anyone is interested…

On KDE Plasma, both left and right click work reliably.

1 Like

What do mean? My middle button works too! :wink:


It was not an exhaustive list of things that work well on KDE Plasma. :joy:

That’s becoming a meme at that point :rofl:

:frog: comes to chat and: “I use KDE, btw!”

P.S. mmmm…my side buttons works like a charm on KDE :yum:

1 Like

I got a bunch of updates on KDE today again. Everything still works.

1 Like

I’m going back to Cinnamon then…I prefer my eggs scrambled! :laughing:

1 Like

I had the same problem using KDE. (Re?)Installing synaptics driver solved the issue here too. It used to be working without problems until recently. I guess one of the last updates screwed things up (just a guess). I can’t remember removing the package. After (re?)installing the driver I just had to reconfigure touchpad settings.

I’ve been trying to work out why my trackpad has all sorts of issues (Clickpad Recognised By Live USB But Not After Installation) and I think that I’m going to have to fall back to the synaptics package but I know that it is no longer actively developed which worries me slightly.