Touchpad not working on Atlantis, can't install

Hello everyone,

Somewhat of a Linux newbie here. I normally use Pop OS, but I have tried Endeavour OS before. Everything worked well (hardware) back then, but my touchpad will not work on Atlantis.

Would this be a kernel issue? How can I fix this if I am unable to move my cursor?

Thanks in advance for any help you can provide.

Welcome to :enos: forums.

Would you be able to post the output of the below command? Post the link.

inxi -Faz | eos-sendlog

While I am not the original poster, I am having similar issues and figured, since you’ve asked for this output, I will give you mine to see if this can assist in getting this fixed for multiple sources:

System:
  Kernel: 5.16.10-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux
    root=UUID=85c7206f-2229-4336-9d1f-d6c2fd747128 rw quiet loglevel=3
    nowatchdog nvme_load=YES
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 7 dm: LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Laptop System: Acer product: Aspire E5-574 v: V1.10
    serial: <superuser required>
  Mobo: Acer model: Zoro_SL v: V1.10 serial: <superuser required>
    UEFI-[Legacy]: Insyde v: 1.10 date: 11/27/2015
Battery:
  ID-1: BAT1 charge: 28.4 Wh (100.0%) condition: 28.4/37.0 Wh (76.9%)
    volts: 17.0 min: 14.8 model: SANYO AL15A32 type: Li-ion serial: <filter>
    status: Full
  Device-1: hidpp_battery_0 model: Logitech K350 serial: <filter>
    charge: 70% (should be ignored) rechargeable: yes status: Discharging
  Device-2: hidpp_battery_1 model: Logitech Wireless Mouse M510
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: Discharging
CPU:
  Info: model: Intel Core i5-6200U bits: 64 type: MT MCP arch: Skylake
    family: 6 model-id: 0x4E (78) stepping: 3 microcode: 0xEC
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 500 min/max: 400/2800 scaling: driver: intel_pstate
    governor: powersave cores: 1: 500 2: 500 3: 500 4: 500 bogomips: 19204
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Acer Incorporated ALI
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300
  Device-2: Realtek HD Webcam - Realtek type: USB driver: uvcvideo
    bus-ID: 1-7:3 chip-ID: 0bda:57cc class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.21.1.3 compositor: xfwm4 v: 4.16.1 driver:
    loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0
    screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
    s-diag: 414mm (16.3")
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5")
    diag: 389mm (15.3")
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 21.3.6
    direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d70 class-ID: 0403
  Sound Server-1: ALSA v: k5.16.10-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.47 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000
    bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    vendor: Lite-On driver: ath10k_pci v: kernel bus-ID: 02:00.0
    chip-ID: 168c:0042 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
Bluetooth:
  Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB
    driver: btusb v: 0.8 bus-ID: 1-5:2 chip-ID: 04ca:3015 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: not found
    rfk-block: hardware: no software: no address: see --recommends
Drives:
  Local Storage: total: 931.51 GiB used: 6.64 GiB (0.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM024 HN-M101MBB
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter> rev: 0001
    scheme: MBR
Partition:
  ID-1: / raw-size: 931.51 GiB size: 915.81 GiB (98.31%)
    used: 6.64 GiB (0.7%) fs: ext4 dev: /dev/sda1 maj-min: 8:1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 40.0 C pch: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 197 Uptime: 9m wakeups: 7 Memory: 15.5 GiB
  used: 1.84 GiB (11.8%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: pacman: 866 lib: 243 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.12

Is the touchpad recognized as a device?

You could post a link for this. I’m sure it’s an elantech.

cat /proc/bus/input/devices | eos-sendlog

You may need to try some kernel parameters. Here are a few that you could test one at a time or a couple. You have to add them to the default grub command line in:

/etc/default/grub 
i8042.nopnp
i8042.reset
i8042.nomux
i8042.kbdreset

Then update grub

sudo grub-mkconfig -o /boot/grub/grub.cfg

@trdunsworth
It could be useful also to post a link to this boot log.

journalctl -p 3 -xb | eos-sendlog

Thank you for the feedback.
Here is the output:

Feb 21 19:11:22 tony-aspiree5574 kernel: x86/cpu: SGX disabled by BIOS.
Feb 21 19:11:22 tony-aspiree5574 kernel: platform MSFT0101:00: failed to claim resource 1: [mem 0xfed40000-0xfed40fff]
Feb 21 19:11:22 tony-aspiree5574 kernel: acpi MSFT0101:00: platform device creation failed: -16
Feb 21 19:11:29 tony-aspiree5574 kernel: hid-generic 0018:04F3:300B.0001: item fetching failed at offset 279/369
Feb 21 19:11:30 tony-aspiree5574 kernel: hid-multitouch 0018:04F3:300B.0001: item fetching failed at offset 279/369

What is this from the boot log? Okay i see that.

Would you be able to try this? It’s a shot in the dark. Add the following to

/etc/modprobe.d/elan.conf
"options psmouse elantech_smbus=0"

Then reboot.

3 Likes

That worked!

Thank you for your help!!!

1 Like

Wow … glad i got it right. So does it show up now as a device?

Edit:

cat /proc/bus/input/devices

Edit: Not sure if this command is what I’m looking for? It may be long so that’s why i added the send log to it in the other post.

Yes, it does now show as a device. The command gave a lot of good info. I’ve been using Linux in various forms for years and I still learn a lot when I run into headaches! Thank you very much!

2 Likes