Touchpad not working in Xfce

Hi, i’m a total newbie to Linux and I have similar problem.
I just installed the latest EndeavourOS with XFCE desktop environtment and my touchpad doesn’t work among other issues.

Here’s the output from the first command you suggest.

I don’t really know how to perform your second suggestion. I tried typing the /etc/default/grub in the terminal but it said “bash: etc/default/grub: No such file or directory”

Is the touchpad still not working? You could try adding this kernel parameter to the default grub command line and then update grub.

1 Like

I have put your issue into a new post since your question is a post-install issue and the original post referred to an older release.

1 Like

Checking out the following pages might help you to narrow down the issue:

1 Like

After familiarizing myself with commandline and the terminal I can finally added the following line to the GRUB

“i8042.nopnp=1 pci=nocrs”

update the GRUB and now it works!
Thank you.

Did you need both parameters to make it work?

Yeah, I need both parameters.
Adding only i8042.nopnp=1 didn’t solve the problem for me.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.