Timeshift: no snapshot shown [SOLVED]

I had timeshift problem as well. Do not compile it. ( rsync downgrade used to be enough back then)
yay -R timeshift
yay -S timeshift-bin
helped me out

Thanks for the suggestion. I tried it, unfortunately it did not solve the issue. The snapshot is still not visible in the Timeshift interface, although it is present in the location where it is supposed to be.

Does that apply too despite the fact that I have set it on a daily schedule?

@eso replacing it is not the solution otherwise someone would of already posted it by now.

I don’t think so. The snapshots should be taken with a cron job running the command line in the background.

Check in the /etc/cron.daily.
Also, you could look at the logs for timeshift at /var/log/timeshift.

1 Like

There is nothing there.

There are logs from the previous Ts version. Today I uninstalled it and installed timeshift-bin as per eso’s recommendation. There currently 2 logs for today. I have the frquency set at daily with 5 max., both as per proposed by Ts itself.

What does systemctl status cronie show?

2 Likes
systemctl status cronie
○ cronie.service - Periodic Command Scheduler
     Loaded: loaded (/usr/lib/systemd/system/cronie.service; disabled; preset: disabled)
     Active: inactive (dead)
1 Like

The cron isn’t running so your timeshift schedule jobs probably also are not running.

sudo systemctl enable --now cronie

Timeshift just assumes there is a running cron available. However, on modern Linux distros, many people use systemd-timers instead of a cron.

2 Likes

If cronie was disabled, how were these snapshots made then?
Manually?

1 Like

Nope, I did not touch Ts after installation. Futhermore, in the TS snapshot location, there was only 1 folder, so only 1 snapshot I assume.

OK, did that, thanks for the tip. So, now I’ll have to wait and see what will happen.

You could list your snapshots in a terminal:

sudo timeshift --list

1 Like
sudo timeshift --list
[sudo] password for peter: 
Mounted '/dev/sda1' at '/run/timeshift/606087/backup'
Device : /dev/sda1
UUID   : 28332fbd-7f8b-493c-81f4-ad91d95e2e4e
Path   : /run/timeshift/606087/backup
Mode   : RSYNC
Status : No snapshots on this device
First snapshot requires: 0 B

No snapshots found

Found stale mount for device '/dev/sda1' at path '/run/timeshift/606087/backup'
Unmounted successfully

What is odd is that under Status it says “No snapshots on this device”, whereas in the actual location there is a Ts folder with the following contents:

image

The rsync log seems awfully big for a log file.

1 Like

@dalto unfortunately, after enabling cronie as per your suggestion, no other snapshots that day 13 Oct, nor today after a reboot.

I have to admit that I misunderstood the problem. Being lazy to reread everything I timidly offer 2 things to consider:
1 - As Servimo writes in https://forum.manjaro.org/t/timeshift-gtk-dumps-core/122478/27

Timeshift keep doing its backup in the background although the gui crash.

But after reopen the gui the backup do not appears, and there is a folder in the timeshift snapshots (I deleted it with thunar-root).

Going to downgrade glib2.

After downgrading to glib2-2.72.3-3 timeshift do it’s job.
i.e.
sudo downgrade glib2
and select the version above. At the end to prevent upgrade of glib2 press y
(2/2) Checking which packages need to be rebuilt
add glib2 to IgnorePkg? [y/N] y

2 - Maybe you have already installed:

  • aur/autoupgrade 1.0.0-1 (+1 0.00)
    Automatic snapshot and then upgrade the system. (When the system fails, run sudo timeshift -- restore and remove this package until the problem is solved.)

I tested several times the timeshift with no GUI crash. Before glib2 downgrade it was unreliable.
(I use XFCE both lts and 6.0.1 kernel)

Thanks for your reply.

The downgrade worked as per your instructions.

Regarding step 2, should I or should I not install the autoupgrade package?

I just want to point out that downgrading glib2 is maybe not the best idea and certainly not sustainable long-term.

Having a library that is shared by so many things out of alignment with the rest of your system could very easily cause a much more critical breakage.

1 Like

OK, good to know, thanks for the heads up.

So, I want to upgrade again, should I do sudo upgrade glib2 ?

First make sure glib2 isn’t in your ignorepkg list in /etc/pacman.conf and then:

sudo pacman -Syu