Timeshift: no snapshot shown [SOLVED]

I installed Timeshift (rsync) and created the first snapshot. Nothing is shown in the main window, i.e. I would not be able to select it to roll back an update (not that I need it now), but in the bottom right-hand corner of the Ts window it shows the partition’s space dropped from 21 GB to 11 GB, i.e. a drop of 10GB

However, when I look in the file explorer, the Ts folder is there, except right-click > properties says it is 11GB in size.

So, my 3 questions are:

  • how can I get the snapshot show up in the Ts window?
  • how come the snapshot is so huge when my personal folders/files are not included?
  • why is there a difference in left over size between the Ts window and file explorer (11 vs 10 GB)?

TLDR; scroll down to comment 80 for the full 3-step solution.

1 Like

Any ideas?

@Klaas-Vaak see this https://aur.archlinux.org/packages/timeshift and this: https://github.com/linuxmint/timeshift/issues/66

Doesn’t seem like it, otherwise someone would have answered.

There’s no screenshot of what you’re seeing in tht GUI, and you haven’t posted the outputs running from terminal. Just an explanation of what you think happened. It’s exceedingly difficult to help in those scenarios. Without tangible things to go off of a lot of people are afraid to help since they turn into 100+ posts.

To me it sounds like something isn’t setup properly, the wiki should help. I can’t compare notes to mine as timeshift isn’t anything I bother with. But some hard visible info and terminal inputs/outputs you will likely have a better chance at someone jumping in to help.

My answers based on info provided:

  1. Once it’s setup properly, it should (it did the last time I used it anyway.)

  2. It’s the size of whatever you told it to backup. So, what did you backup?

  3. What is “file explorer” and it could be a rounding error.

Thanks for your reply.
I left out further data because I was not sure what was required.

What do you mean by that? What would you like to see specifically?

Here are the settings I have:

image

image

image

“file explorer” is … well, file explorer - I don’t know what else to call Nemo.

As for something not being set up properly, that sounds strange to me since I accepted all the settings proposed by Ts, incl. the location for the snapshots. But maybe that is a problem? This is what Nemo looks like:

image

The snapshot location is the 21GB partition.

1 Like

I guess it’s working. I know the first backup was big and then subsequent were less. But but 10/11gb isn’t much.

When I needed to use it I ran it from terminal from chroot.

So how come the the snapshot isn’t showing in the Ts window itself?

1 Like

I wouldn’t have a clue, I don’t use timeshift. I don’t bother backing up anything other than photos and documents.

Could you should a complete screenshot of where you expect to see it? Please include the entire application, not just a snippet of it.

All the snapshots are normally listed here:

image

Then you can select the one you want to restore and click on it.

That does seem like it may be broken. This may be something you need to report upstream to the timeshift developers.

1 Like

What tells you it seems to be broken?

Exactly what you have already described. The fact that you took a snapshot, it consumed disk space but isn’t on the list.

1 Like

Ah, OK, I thought there was something more esoteric.
Thanks for your input.

BTW, is there another system like Ts that you are aware of, @dalto ?

Just out of interest: if your system gets borked you don’t have a back-up, so that means reinstallation, correct?

There are plenty of tools that take rsync-based backups. But I have never used another tool that can roll-back an rsync-snapshot like timeshift can.

I had the same problem recently on a new installation, but I removed Timeshift. In my case, the program broke when creating a snapshot, but it took its place on the HD, just like you.

Did you reinstall Timeshift? If so, was the problem gone?

I tried everything with no help.

1 Like

But did you manage to solve the problem? If so, how?