Time error UTC becomes Local Time

My System time is showing 8 hrs ahead of Local time.At the same time UTC got pushed ahead by 8 hrs.
How do i get UTC time back to normal?. UTC need to be set backward by 8 hrs.
This happened when i had to remove battery to get rid of outer space hacking activity which took control of bash terminal.

you can try: sudo systemctl restart systemd-timesyncd.service

Maybe time is wrong in BIOS. Can you check it in BIOS?
if it is not correct, you need to change it in BIOS or run $ sudo hwclock --systohc to set time in BIOS.

timedatectl set-npt true

I did that several times. It didn’t help. I am using ntpsec package.Not ntp

It didn’t help.

tried timedatectl set-ntp true. it didn’t help along with all possible solutions
sudo systemctl start ntpd.service
timedatectl set-local-rtc 0
sudo systemctl enable --now systemd-time-wait-sync.service
sudo timedatectl set-time “2023-05-21 09:47:20”- error says auto synchronization

sudo timedatectl show-timesync --all displays the following

FallbackNTPServers=0.arch.pool.ntp.org 1.arch.pool.ntp.org 2.arch.pool.ntp.org 3.arch.pool.ntp.org
PollIntervalMaxUSec=34min 8s
PollIntervalUSec=4min 16s

How can we reset UTC to normal from its wrong time of HKT?

Is your bios set to UTC time? Your settings indicate it should be.

Yes . I did manually set bios time to UTC after removing battery to erase hacker activity inside bash kernel.

Didn’t you already have a posting on this same issue? :thinking:

UTC != Local time.
UTC + 8 (Hong Kong time zone) = Local time, that should be the expectation. No issue!

I noticed that you disabled “system clock synchronized”
See your screenshot:

System clock synchronized: no

You need to enable it.

Check what is the output: $ systemctl status systemd-timesyncd.service

and check NTP config: $ cat /etc/systemd/timesyncd.conf

I see, hardware clock stops working when your computer is offline without power. If you boot your OS to read inactive hardware clock, that is why it shows wrong time after boot.

Maybe you need to make system time independent of hardware clock from BIOS.

You need to enable $ sudo systemctl enable --now systemd-timesyncd.service
and can additionally create a special systemd service script that should be run to immediately synchronize the time from the online network on startup.

sudo hwclock --systohc
STEP3 ::sudo systemctl start systemd-timesyncd.service
STEP4:: sudo timedatectl show-timesync --all
STEP5::sudo timedatectl timesync-status
STEP6::sudo timedatectl status
STEP7::sudo systemctl enable systemd-networkd
STEP8::sudo timedatectl set-ntp true
ntpsec package installed not ntp

Output of systemctl status systemd-timesyncd.service and
cat /etc/systemd/timesyncd.conf

Yes. Closed it as ZTE router reset solved the issue.
Now it is mobile 4g network hotspot from same ISP airtel.
There is nothing to reset at my end.