Ntp sec time sync

Hacker has been able to change local time.
I tried to manually change local time using

sudo timedatectl set-time “2022-10-20 16:57:00”

Error says automatic sync enabled.

STEP2:: Then i tried to set hardware clock time to system time
sudo hwclock --systohc

It did not sync local time with hardware clock which is HKT

STEP3 ::sudo systemctl start systemd-timesyncd.service
STEP4:: sudo timedatectl show-timesync --all
Result as below

SystemNTPServers=0.arch.pool.ntp.org 1.arch.pool.ntp.org 2.arch.pool.ntp.org 3.arch.pool.ntp.org
FallbackNTPServers=0.arch.pool.ntp.org 1.arch.pool.ntp.org 2.arch.pool.ntp.org 3.arch.pool.ntp.org
PollIntervalMaxUSec=34min 8s
PollIntervalUSec=8min 32s

STEP5::sudo timedatectl timesync-status
Server: (3.arch.pool.ntp.org)
Poll interval: 8min 32s (min: 32s; max 34min 8s)
Packet count: 0

STEP6::sudo timedatectl status
Local time: Fri 2022-10-21 01:52:21 HKT
Universal time: Thu 2022-10-20 17:52:21 UTC
RTC time: Thu 2022-10-20 17:52:21
Time zone: Asia/Hong_Kong (HKT, +0800)
System clock synchronized: no
NTP service: active
RTC in local TZ: no

STEP7::sudo systemctl enable systemd-networkd
STEP8::sudo timedatectl set-ntp true
ntpsec package installed from yay.
Not ntp package

Please help me to correct local time back to HKT

Hardware clock is set to HKT not GMT
Now UTC is HKT
Local time is 6 Hrs Behind HKT.
That is GMT+2.

Tried to reset ISP router IP ,DHCP
Then automatically my Local time got finally settled to HKT and UTC to GMT as solicited.

                   $sudo timedatectl status

           Local time: Mon 2022-10-31 00:01:57 HKT
       Universal time: Sun 2022-10-30 16:01:57 UTC
             RTC time: Sun 2022-10-30 16:01:58
            Time zone: Asia/Hong_Kong (HKT, +0800)

System clock synchronized: no
NTP service: active
RTC in local TZ: no
$sudo timedatectl timesync-status
Server: (3.arch.pool.ntp.org)
Poll interval: 34min 8s (min: 32s; max 34min 8s)
Packet count: 0

Looks like timesyncd and networkd daemons of systemd worked for me with ntpsec .
Probably ISP might have been masking/blocking the router packets against ntpserver sync as google being networking tech partner for my ISP has been doing some strange things off late with my router mac, assigning IP on WAN side mac with out any country designation (IANA) with NAT mask for which is USA IP
Outgoing traffic from PC diverted to WAN IP assigned by them by passing router LAN and NAT. Just like bridging two routers,here it is single router with out its functionality.
I can not do anything in a weird country where google is praised and prayed as holly book,word.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.