Thunderbird printing

Guys, I have Tbird 102.7.0, and have used it since beta. Only now having a strange issue where I needed to print an email; the print dialog appears, I choose my network printer, click print, the dialog leaves…nothing happens. No report on command line. Same in Tbird safe mode. I also cleared out all print settings in the config editor.
I can print to the local PDF without problems, and then go and use Okular to open that PDF and print it.
I am on Plasma, so wondered if it’s a snarl up between QT and GTK libraries. I checked Firefox printing, and it has the same issue.

Anybody have any idea where to start poking this bear?

Do you have GTK_USE_PORTAL set?

1 Like

No it wasn’t; thanks I was unaware of that one. So I set that, verified it with printenv | grep GTK, and ran Tbird. I now have Plasma Portal for the file dialog, but printing is still not functional.

1 Like

I don’t have a network printer. Mine is connected directly to usb. Maybe it’s printing to :rofl:

1 Like

I printed to PDF fine again, in order to do the following:
I checked the CUPS logs…nothing.
I checked the journalctl -xe …nothing.

It is bemusing that Tbird doesn’t log this stuff.

How does printing to a PDF relate? Doesn’t that just create a new file? It’s not actually using the printer and printing? :thinking: Or am i wrong?

1 Like

PDF printing does require a process of conversion to postscript, which I assumed Tbird would use the printing libraries for. Maybe it bypasses them altogether, but if so, then why does the print dialog only show the printers that CUPS has available?

Maybe this explains it since you talk about the process of conversion to post script instead of why the printer isn’t printing. :man_shrugging:



1 Like

Very interesting…using the
tail -n 100 -f /var/log/cups/error_log
as per the archwiki troubleshooting page, at debug level, I can see that opening Tbird’s print dialog runs through the CUPS system in order to populate the dialog. I can also see that hitting the print button does nothing; it is not passed back to CUPS to process. I am suspecting that this is a Tbird bug. I have also installed Betterbird, just for giggles, and it has the same result, but is the same base version.

What kind of a printer is it? Is it low on ink? Some printers when they get low won’t print.

1 Like

Konica Minolta c284e humongous colour network copier I picked up cheaply because they didn’t want to service it, a year ago. I gave it a new transfer roller and replaced the toners that were low, and it prints beautifully. Except for Tbird :grin:

I don’t use network printers but i have no issue printing from email on Thunderbird that I’m aware of. I haven’t used it in a while though. It’s a laser black but is hooked to usb.

Edit: I will try it later as my printer is low on toner anyway. I have a new toner cartridge sitting here waiting to install.

1 Like

I have an HP Color Laser MFP 179fnw using wifi and TB is fine.

1 Like

the print dialogue is the same as used for firefox:

have you tried using the option print with system dialogue?

Yes, still nothing.

it does not open any system print dialogue or it does and is still not printing?

1 Like

It does, exactly as you see it, but the Print button, with the Konica selected, merely makes the print dialog disappear.

Have you tried removing the printer altogether and starting over. Start from scratch and see if you were missing something.

1 Like

as far as i understand he can print when not using Mozilla apps… only the internal Mozilla print dialogue is failing… but not sure… needs more details to be able to investigate more…

1 Like

When i go to print an ERmail out of Thunderbird it shows this window popup:

I can print from this here on kde pressing the print button bottom left… but i can also open kde internal print window when i press the link in the right middle say “use system dialogue” this opens kde internal print dialogue:

also from there i can print… but… in both cases it will close the window when pressing print… and it will open i tray icon on the panel:


Queue and settings …

from this you can reach the printer settings and may queue also if print was not working may… vcaused by wrong setting used… like thunderbird try to print in letter but you need A4 to print… printer stops and hold the jobs in the queue … also if you try a new one …

1 Like