The thunar "GLib-GIO:ERROR" after glib2 2.74.3-1 update to glib2 2.74.4-1

Hi guys!
Couldn’t find it in the Internet, posting.

The thunar file manager is shutting down immediately after start with the error:

❯ thunar
GLib-GIO:ERROR:../glib/gio/gmenuexporter.c:275:g_menu_exporter_menu_items_changed: assertion failed: (added < G_MENU_EXPORTER_MAX_SECTION_SIZE)
Bail out! GLib-GIO:ERROR:../glib/gio/gmenuexporter.c:275:g_menu_exporter_menu_items_changed: assertion failed: (added < G_MENU_EXPORTER_MAX_SECTION_SIZE)
Aborted (core dumped)

Steps to reproduce (on my machine):

  1. Upgrade glib2.
  2. Reboot.
  3. Open thunar.


  • EndeavourOS build 2022.09.10
  • Gtk 3.24.36
  • Kernel 6.1.1-arch1-1
  • LG Gram 16 2021

What I have already tried:

  1. Install EnOS on a VM. I couldn’t reproduce the error. Everything is working on VM.
  2. Install “vineliuice github whitesur-gtk-theme” on VM to close it up with my main machine. Everything is working on VM.
  3. Install “plank” and “vala-panel-appmenu” on VM to close it up with my main machine. Everything is working on VM.
  4. Trying to find the solution on “gmenuexporter github” page. Without any clues.
  5. Reinstall thunar with all dependencies on a main machine. It doesn’t fix the error on the main machine.
  6. Tried sudo thunar and it works. But do not know what to derive from it.

If you have any solutions I will be glad to hear from you. Have a nice day!

Upgrade glib2? By itself? You didn’t by any chance perform a partial upgrade, right?

Reinstalling OS from the scratch with standard Arc Dark theme doesn’t solve the problem. The problem still persist and I do not know what to do. Posted the bug on Thunar GitLab.

  • After reinstalling the OS did you upgrade the glib2 again?
  • What do you mean by Upgrade glib2? Did you do a sudo pacman -Syu or you did sudo pacman -S glib2?

I’ve been using XFCE/Thunar for ages now even upgraded to 4.18. Everything works with no issues at all. In your bug report, you say it worked for one day after installing it from scratch.

First of all, there are a few things that are seriously wrong here. The package glib is no longer available in the official repo and AUR, and the latest version of thunar depends on glib2, not glib (if you run pactree thunar, you can see that it depends on glib2, not glib).

The error message referenced a file on your system named ../glib/gio/gmenuexporter.c, but this file should not be there if you’d upgraded your system correctly. For glib2, the gmenuexporter file is a C header file (with .h extension) as opposed to a C source file.

This means that for some reason, glib is still installed on your system, which shouldn’t be the case because the package glib is no longer on the AUR or official repo. It also means that the version of thunar that is currently installed on your system is somehow still using glib even though the latest version of thunar in the official repo depends on glib2, not glib.

thunar and glib2 has the same Build Date (thunar was built after glib2), so it’s possible that thunar has been rebuilt to use glib2 when glib was replaced with glib2 in the official repo. From this, we can infer that you have somehow upgraded glib to glib2 without also upgrading thunar. In other words, you have likely performed a partial upgrade.

Here are a few things that you can do.

  1. Run sudo find / -name gmenuexporter.c to obtain the full path of the file reported in the error message. Then, use pacman to check which package owns that file (by running pacman -Qo /full/path/to/glib/gio/gmenuexporter.c). If you are using glib2 that file shouldn’t even be there? On glib2 the file should be /usr/include/glib-2.0/gio/gmenuexporter.h

  2. Run pacman -Qi thunar to see if you have the latest version of thunar. The latest version in the official repo (at the time of this writing) is 4.18.1-1.

  3. If your thunar isn’t up-to-date, run sudo pacman -Syu. Hopefully this would resolve the issue.

1 Like

@anthony93 @s4ndm4n
Guys, hi! First of all, thank you for coming by and for answers.
But second, why do you read from my post something what it doesn’t contain? Maybe it is my English. Sorry if so. I will try to clarify everything in this message.

In short:

  • I didn’t do a partial upgrade.
  • I don’t have the old version of thunar.
  • I don’t have an old glib in my system.

I am very grareful that you came by, but you choose the wrong direction.

I tried to be more specific with my question so I found the package in upgrade what caused the problem. It was glib2 2.74.3-1 update to glib2 2.74.4-1 (with the yay -Syu command). I don’t know where to go further to solve a problem.

Thank you again for answers. I still don’t know what to do else.
As you see, now I even reinstalled EnOS with the latest ISO. And thunar worked one day. On the second day it gave me the same error with glib.

@Katie We are just trying to help.

Thunar is complaining about gmenuexporter.c

That’s the thing. Glib2 DOESN’T own that file. It should be gmenuexporter.h

That’s why I asked you to check which package owns that file and also check which version of thunar is currently on ur system.

If ur system is up-to-date and in sync with the official repo, there’s no reason why Thunar won’t work.

Have you tried to perform these steps?

Please try to at least check the version of thunar on ur system?

pacman -Qi thunar
1 Like

That’s exactly why we all suspect a partial upgrade. Thunar was working fine when you first installed Endeavour, and then it broke the next day. Something must have happened in between to mess up its dependencies.

If you did something before you reinstalled EOS and it broke thunar, and then do something similar after u reinstall EOS, thunar will likely break again, which is exactly what happened in your case.

Thunar was working fine after you reinstalled EOS. U used the system for one day (you do stuff in between, install packages? Upgrade system), and then thunar broke exactly the same way it broke before u reinstall.

Surely you can see a problem here?

Yes, performed, of course. Everything is up to date.

I believe it might be something with vala-panel-appmenu, you can read my thoughts about it in the thunar gitlab issue post. It uses the DBus, maybe there is the place where the problem occurs?

If you have performed them, then can u please post the result of steps 1 and 2?

1 Like

Of course. This is the reason I mentioned that I did standart Arc Dark theming and vala-panel-appenu install. But I had it working for many months before experiencing this problem.

How did you install these? With yay or some other package manager? Did you run an installation script you downloaded from github?

1 Like

Of curse.

There is no gmenuexporter.c in my system.

$ sudo find / -name gmenuexporter.c
find: ‘/proc/3727/task/3727/net’: Invalid argument
find: ‘/proc/3727/net’: Invalid argument
find: ‘/run/user/1000/doc’: Permission denied
find: ‘/run/user/1000/gvfs’: Permission denied
find: ‘/tmp/.mount_BitwarQPpLuh’: Permission denied
find: ‘/tmp/.mount_Jopling7eNPS’: Permission denied

$ sudo find / -name gmenuexporter.h
find: ‘/proc/3727/task/3727/net’: Invalid argument
find: ‘/proc/3727/net’: Invalid argument
find: ‘/run/user/1000/doc’: Permission denied
find: ‘/run/user/1000/gvfs’: Permission denied
find: ‘/tmp/.mount_BitwarQPpLuh’: Permission denied
find: ‘/tmp/.mount_Jopling7eNPS’: Permission denied

So nothing owns this file.

$ pacman -Qo /full/path/to/glib/gio/gmenuexporter.c
error: No package owns /full/path/to/glib/gio/gmenuexporter.c

I have the latest thunar install.

$ pacman -Qi thunar
Name            : thunar
Version         : 4.18.1-1
Description     : Modern, fast and easy-to-use file manager for Xfce
Architecture    : x86_64
URL             :
Licenses        : GPL2  LGPL2.1
Groups          : xfce4
Provides        : None
Depends On      : desktop-file-utils  libexif  hicolor-icon-theme  libnotify  pcre2  libgudev  exo
                  libxfce4util  libxfce4ui  libpng
Optional Deps   : gvfs: trash support, mounting with udisk and remote filesystems [installed]
                  tumbler: thumbnail previews [installed]
                  thunar-volman: removable device management [installed]
                  thunar-archive-plugin: archive creation and extraction [installed]
                  thunar-media-tags-plugin: view/edit ID3/OGG tags [installed]
Required By     : thunar-archive-plugin  thunar-media-tags-plugin  thunar-volman  xfdesktop
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 8,36 MiB
Packager        : Evangelos Foutras <>
Build Date      : četvrtak, 22. decembar 2022. 15:30:45 CET
Install Date    : ponedeljak, 02. januar 2023. 23:29:23 CET
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

That’s certainly interesting. I will investigate further once I have access to my computer.

I installed everything with yay. The particular steps I mentioned on thunar gitlab issue post.

I do not think the problem in a way I installed it, but in a way vala-panel-appmenu works, But it’s only recent indea derived in my head from thunar contributor message.

pacman -Qo /usr/include/glib-2.0/gio/gmenuexporter.h

/usr/include/glib-2.0/gio/gmenuexporter.h is owned by glib2 2.74.4-1

An easy way to test it out would be to uninstall vala-panel and then see if thunar still complains.

pacman -Qo /usr/include/glib-2.0/gio/gmenuexporter.c will not show this as the file does not exist

Yeah. That’s exactly why I asked her to use the find command to find where that file is. Where does that file come from?