The command pacman returned error code 1

What I’ve done :

  1. Using EOS Artemis 22.6
  2. Using Rufus with DD image mode
  3. Installing Community Edition
  4. Choose OpenBox one
  5. I can’t find pcurses option (Because this was the solution of previous build)

This happened to me everytime, even in VirtualBox
Check this out guys → https://termbin.com/600h

022-07-15 - 13:30:08 [6]: [PYTHON JOB]: "error: xbindkeys: signature from \"Konstantin Gizdov <arch@kge.pw>\" is marginal trust" 
2022-07-15 - 13:30:08 [6]: [PYTHON JOB]: ":: File /var/cache/pacman/pkg/xbindkeys-1.8.7-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature))." 
2022-07-15 - 13:30:08 [6]: [PYTHON JOB]: "Do you want to delete it? [Y/n] error: failed to commit transaction (invalid or corrupted package)" 
2022-07-15 - 13:30:09 [6]: [PYTHON JOB]: "" 
2022-07-15 - 13:30:09 [6]: [PYTHON JOB]: "Errors occurred, no packages were upgraded."

Try updating archlinux-keyring in the live session before launching the installer:

sudo pacman -S archlinux-keyring

Also, welcome to the community @Habu!

:enos_flag: :handshake:t5:

2 Likes

Yeah thank you for welcoming me, I’m happy to get into this community. Anyway here’s the result when I run the command. It seems stuck even I connected to the Internet

1 Like

Make sure you have network connection in the live session and try:

sudo pacman -Sy archlinux-keyring

Edit:

The latest version is: 20220713-1

3 Likes

Wow thank you so much. This is worked for me, I’m almost giving up lmao. THANKSS

1 Like

You are welcome!
Glad you got it working!

:enos_flag:

1 Like

Thank you so much! I was having this exact issue and your command saved me! I almost gave up after trying for almost ten times with the installation process.

1 Like

I am glad you could get it to work!

Welcome to EnOS’ community @kohane27!

:enos_flag: :handshake:t5:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.