Terminal font problem

Hi,

Here is a problem with the XFCE terminal :


I changed the language to see if it was the encoding…
I’m not a programmer so I can’t help myself more.

Thank you!

Hi, and welcome!

Here’s an extensive discussion of this issue. The solution relates to the terminal font choice. I hope this will help solve your problem:

If changing the font doesn’t work, please report back!

Thank you.
To change the font preference ruled out the problem.

Hello my friend !
Few more questions please ?
Are you using OhMyZsh + Zsh ?
Have you tried to customized your terminal ?
Are you using an European encoding method ?

Please your answer will help us help you !

Helo my friend i see you still have no solution to your problem !
I would like to suggest you check if your encoding is similar to the one in my below screenshot UTF-8 in this case (if your home language doesn’t require special encoding stuffs) if it’s not the same as mine and your are using english or french or any similar language but not a special language such as chinese, arabic, hebrew etc thus using different characteristics then please consider to switch your encoding back to the one in the screenshot, save the changes, check your actual font, would advice you make it Noto Sans with size 10 or 11 (depending on your taste) this to be safe then save it all, close your terminal and reload your it, it should work straight !

… you should choose to edit the actual profile to find that option for your terminal, Tilix, Konsole, gnome terminal or xfce termainl they all give you that option.

please mark the post as solved