Systemd-boot and refind

On a previous flawless fresh install on a MSI Laptop with systemd-boot selected, refind detected the Gummiboot. On another MSI Laptop, it does not. No way to boot into EOS. I tried a re-install but did not succeed. Any ideas?

So, I tried various re-installations etc. but no success. Finally, arch-chroot from the Live-USB, does not work because /efi cannot be mounted because it does not exist.

Any ideas as to why it is not created? Thanks.

Gummiboot is the predecessor of systemd-boot. Refind is a bootmanager, so is systemd-boot. Do yiu have two bootmanagers installed?

Can we get information about your hardware withinxi -F and your current partitioning?

Sorry, I tought they are synonyms because the icon in refind looks like it.
I have only refind and often it start the kernels directly when shown.
Here the output from the Live USB.

[root@EndeavourOS liveuser]# inxi -F
  Host: EndeavourOS Kernel: 6.1.7-arch1-1 arch: x86_64 bits: 64 Desktop: Xfce
    v: 4.18.1 Distro: EndeavourOS
  Type: Laptop System: Micro-Star product: Modern 15 A5M v: REV:1.0
    serial: 9S7155L26042ZL6000040
  Mobo: Micro-Star model: MS-155L v: REV:1.0 serial: BSS-0123456789
    UEFI: American Megatrends LLC. v: E155LAMS.114 date: 10/31/2022
  ID-1: BAT1 charge: 24.0 Wh (51.1%) condition: 47.0/52.4 Wh (89.6%)
    volts: 11.5 min: 11.4
  Info: 8-core model: AMD Ryzen 7 5700U with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 1475 min/max: 1400/4370 cores: 1: 1800 2: 1400 3: 1800
    4: 1400 5: 1400 6: 1400 7: 1400 8: 1400 9: 1400 10: 1400 11: 1400 12: 1400
    13: 1800 14: 1400 15: 1400 16: 1400
  Device-1: AMD Lucienne driver: amdgpu v: kernel
  Device-2: Acer HD Webcam type: USB driver: uvcvideo
  Display: server: X.Org v: 21.1.6 driver: X: loaded: amdgpu
    unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu
    resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 22.3.3 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.49 6.1.7-arch1-1)
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_rn_pci_acp3x
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Sound API: ALSA v: k6.1.7-arch1-1 running: yes
  Sound Server-1: PipeWire v: 0.3.64 running: yes
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
  IF: wlan0 state: down mac: 16:25:50:b5:20:c6
  Device-2: ASIX AX88179 Gigabit Ethernet type: USB driver: cdc_ncm
  IF: enp4s0f3u1c2 state: up speed: N/A duplex: half mac: f8:e4:3b:b6:53:1b
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 491.82 GiB used: 0 KiB (0.0%)
  ID-1: /dev/nvme0n1 vendor: Kingston model: OM8PCP3512F-AI1
    size: 476.94 GiB
  ID-2: /dev/sda type: USB vendor: Innostor model: N/A size: 14.88 GiB
  ID-1: / size: 10 GiB used: 99.5 MiB (1.0%) fs: overlay source: ERR-102
  Alert: No swap data was found.
  System Temperatures: cpu: 20.6 C mobo: N/A gpu: amdgpu temp: 14.0 C
  Fan Speeds (RPM): N/A
  Processes: 327 Uptime: 11m Memory: 14.99 GiB used: 1.96 GiB (13.1%)
  Shell: Bash inxi: 3.3.24
/dev/nvme0n1p1       2048     616447    614400   300M EFI System
/dev/nvme0n1p2     616448     649215     32768    16M Microsoft reserved
/dev/nvme0n1p3     649216  256663551 256014336 122.1G Microsoft basic data
/dev/nvme0n1p4  256663552  258760703   2097152     1G Linux filesystem
/dev/nvme0n1p5  258760704  273125375  14364672   6.8G Linux swap
/dev/nvme0n1p6  400281600  471482367  71200768    34G Microsoft basic data
/dev/nvme0n1p7  503470080  715558911 212088832 101.1G Linux filesystem
/dev/nvme0n1p8  715558912  717656063   2097152     1G Linux filesystem
/dev/nvme0n1p9  717656064  759586815  41930752    20G Linux filesystem
/dev/nvme0n1p10 759590912  767846399   8255488   3.9G Linux swap
/dev/nvme0n1p11 767846400 1000214527 232368128 110.8G Linux filesystem
/dev/nvme0n1p12 273125376  358561791  85436416  40.7G Linux filesystem
/dev/nvme0n1p13 358561792  400279551  41717760  19.9G Linux filesystem
/dev/nvme0n1p14 471482368  503470079  31987712  15.3G Microsoft basic data

hello Thomas. Did you ever try a reinstall with option “no bootloader” ?
on my multiboot this always works fine

hi Colin. I may try but I meant to have systemd-boot on. In particular, on my other MSI Laptops, it installs fine. How come /efi not created by the installer?

there is a partition /efi
did you mount here using the installer ?

Judging by the partitioning information you are already having a multiboot system in place with Windows and one or two other Linux OS, is that right?

And you said you are already using refind? So, why do you want to install systemd-boot in addition? If you want do change the bootmanager, you should replace refind from the distro you installed it from, in my opinion.

refind is installed from the live USB. It does not find endeavouros i.e. it cannot be used and arch-chroot is not possible either due to the missing /efi as said.

All of this looks like a flaw in the installer given that an installation works fine on 2 other MSI Laptops.

To answer your question: Windows, Centos, QubesOS and (EndeavourOS).

And what bootmanager are you currently using on that machine? I mean, as from what I understood you want to add Endeavour as a fourth Distro/OS. So, there must be a working bootmanager in place already that is probably installed by one of the other distros, or did I misunderstand something?

Edit: In that case, as Colin suggested, I would install without bootloader and switch the bootloader fromm whatever distro it’s installed by

1 Like


mount /dev/nvme0n1p7 /mnt # system partition # first!
mount /dev/nvme0n1p1 /mnt/efi # efi partition # second!
arch-chroot /mnt

IMHO, using refind and starting the kernel directly does not require a boot manager (not valid for all distros). However, refind needs to find them.

Not sure, but wouldn’t /mnt/boot/efi be a better way to mount your efi-partition?

But refind is a bootmanager. From what distro did you install it?

Did you try installing Endeavour without bootmanager and see if refind finds it?

when in chroot, I run bootctl install according to and now see the icon in refind; but it does not allow yet to get into EOS. I have to configure it properly. All of that has not been necessary with the other (edit) installations. I really wonder what goes wrong here.

directly from the live USB as said.

I will try that.

The problem however seems that the installer does not create /efi/EFI/systemd i.e. runs bootctl install. I propose that the developers should have a look at the code.

I am sorry, my brain seems to be a bit slow today, but I still don’t fully understand.

So, you have a machine with Windows, CentOS and QubesOS already up and running. EndeavourOS being not yet installed.

You use refind as bootloader which you didn’t install but boot into a USB device or you installed from a live USB? If you did install refind from a live USB I still don’t know from which live USB. You installed it with this refind-install script without using a distribution specific package?

By default I think it would be /boot/efi/EFI/endeavouros/ if we are talking about the directory the .efi file is placed

such a directory is missing and should have been created from the installer.

Let me try and explain: I have 3 MSI Laptops with almost identical installation and setups. 2 of them work well but the 3rd is having these problems.

I have a Live USB w/ EOS which I only use for installations and repair. On this, I install refind and run refind-install. It is very clever and installs itself on the Laptops.

Would it possible for someone to look at the code when this is created?