Systemctl enable not working, no login screen and no internet by default

Just installed the system via offline installation and i was greeted by instead of a login screen, by a terminal, lightdm didn’t boot with the system, okay i did:

sudo systemctl enable lightdm.service

sudo systemctl start lightdm.service

And it worked fine, then i proceed to see that I’m not connected to the internet! Okay repeat the process, i do:

sudo systemctl enable

And the system answers me with:

The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
• A unit may be statically enabled by being symlinked from another unit's
  .wants/ or .requires/ directory.
• A unit's purpose may be to act as a helper for some other unit which has
  a requirement dependency on it.
• A unit may be started when needed via activation (socket, path, timer,
  D-Bus, udev, scripted systemctl call, ...).
• In case of template units, the unit is meant to be enabled with some
  instance name specified.

i go like, okay, maybe it will start working after i start it once so i do:

sudo systemctl start

then nice, internet is back!
i reboot the system to test and wow, no login screen again, i need to do the first part again and after that i can see that internet also didn’t boot, like, in internet enable at least gave me an error but in lightdm it should have enabled it but it didn’t! every time i reboot the system these two always stop working.

(why these things happen to me, its because my pc is bad? pain)

1 Like is not enabled on a default EOS install. Check the status of these services:


Let’s get this working first, then we’ll tackle the lightdm.service problem. One question: what DE are you using?

1 Like

Ok! Im on the default one xfce

And how do i check their status?

Now i need to sleep, tomorrow I’ll be back, bye!

1 Like

For .target files enable might be a wrong command.

And now I’m back!

Oh, what would be right then?

sudo systemctl enable NetworkManager
1 Like

Oooh, will try it, thanks!

But enable doesn’t work on lightdm… Will this work? Let me see

It worked! Thank you so much you just fixed half of my problem!

But here i am, with lightdm still broken

systemctl status NetworkManager.service

would show status…
But the underlying issue is something else… as both should be enabled from the install already.
The install was finished without error warning ?
Could you show installer log please?

sudo cat /var/log/endeavour-install.log | eos-sendlog

It had a bootloader installantion error, it happens in basically every arch based sistem with grub installation for me, thats why i use rEFInd
This instalation log stay in the sistem even after it is installed already? Didn’t knew that

Oh, and now i took a look at lightdm status and it says that the preset is disabled…

Oh, and there is no endeavour-install.log file in the /var/log folder here

thats what io mean… if installer stops it will not run steps after the fail that calls the stop it will skip all these… and if bootloader was the failpoint it will not enable systems stuff:

  • eos_bootloader
  • grubcfg
  • windowsbootentry
    - bootloader
  • eos_script@cleaner_script
  • eos_script@chrooted_cleaner_script
  • services-systemd
  • preservefiles
  • shellprocess@copyfiles
  • umount

this will lead to basically a partly-installed system and not a full EndeavourOS.

Oooooooooooooooh, then how do i fix the grub install error?

Shoud i try to reinstall then send log?

you could do this and send the log before rebooting as it is available from the live session too:

cat ~/endeavour-install.log | eos-sendlog

or use the log tool from panel…
I am sure ewe can help to finish installation on your device if we see this…