System won't boot graphically with Kernel 5.2.14

Hi guys. I am having the problem that my system will not boot into the desktop with Kernel 5.2.14. This does not occur with the LTS Kernel 4.19.72.
Any suggestions where to start to fix this problem?
J.

Could you post some hardware info? inxi -Fxxc0

System: Host: p707 Kernel: 4.19.72-1-lts x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.5
tk: Qt 5.13.1 wm: kwin_x11 dm: SDDM Distro: Antergos Linux
Machine: Type: Laptop System: Notebook product: P65_67HSHP v: N/A serial: Chassis: type: 10
serial:
Mobo: Notebook model: P65_67HSHP serial: UEFI [Legacy]: American Megatrends
v: 1.05.14 02/23/2018 date: 02/23/2018
Battery: ID-1: BAT0 charge: 57.6 Wh condition: 57.6/60.2 Wh (96%) volts: 16.3/14.8 model: Notebook BAT
serial: 0001 status: Full
CPU: Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake rev: 9
L2 cache: 6144 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44928
Speed: 900 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 918 2: 906 3: 931 4: 924 5: 908 6: 915
7: 959 8: 915
Graphics: Device-1: NVIDIA GP106BM [GeForce GTX 1060 Mobile 6GB] vendor: CLEVO/KAPOK driver: nvidia v: 435.21
bus ID: 01:00.0 chip ID: 10de:1c60
Display: x11 server: X.Org 1.20.5 driver: nvidia unloaded: fbdev,modesetting,nouveau,vesa
alternate: nv compositor: kwin_x11 resolution: 1920x1080~75Hz
OpenGL: renderer: GeForce GTX 1060/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 direct render: Yes
Audio: Device-1: Intel CM238 HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus ID: 00:1f.3
chip ID: 8086:a171
Sound Server: ALSA v: k4.19.72-1-lts
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK driver: r8169
v: kernel port: d000 bus ID: 6d:00.1 chip ID: 10ec:8168
IF: enp109s0f1 state: down mac: 80:fa:5b:42:e9:4d
Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: d000 bus ID: 6e:00.0
chip ID: 8086:24fd
IF: wlp110s0 state: up mac: 00:28:f8:05:d3:a9
Drives: Local Storage: total: 256.17 GiB used: 120.59 GiB (47.1%)
ID-1: /dev/sda vendor: Crucial model: CT275MX300SSD4 size: 256.17 GiB speed: 6.0 Gb/s
serial: 164714C1B49E
Partition: ID-1: / size: 243.27 GiB used: 120.48 GiB (49.5%) fs: ext4 dev: /dev/sda2
ID-2: /boot size: 242.9 MiB used: 105.8 MiB (43.5%) fs: ext4 dev: /dev/sda1
ID-3: swap-1 size: 7.75 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5
Sensors: System Temperatures: cpu: 61.0 C mobo: N/A gpu: nvidia temp: 50 C
Fan Speeds (RPM): cpu: 3654
Info: Processes: 212 Uptime: 3h 04m Memory: 15.61 GiB used: 3.78 GiB (24.2%) Init: systemd v: 243
Compilers: gcc: 9.1.0 alt: 4.9/4.9.4/5 Shell: bash v: 5.0.9 running in: konsole inxi: 3.0.30

It looks like you are using the Nouveau driver for the Nvidia card on the lts kernel. I see this an Antergos original install. Did you ever use a normal kernel before or was it always on the lts kernels?

lspci -k | grep -A 2 -i "VGA"

lspci -k | grep -A 2 -i “VGA”
01:00.0 VGA compatible controller: NVIDIA Corporation GP106BM [GeForce GTX 1060 Mobile 6GB] (rev a1)
Subsystem: CLEVO/KAPOK Computer GP106BM [GeForce GTX 1060 Mobile 6GB]
Kernel driver in use: nvidia

Usually I am using the standard kernel, but I have the ls kernel installed as “fallback”, just in case there’s a problem with the standard kernel.
J.

It looks like it’s using the standard nvidia driver. Was it booting before on the current kernel? I have the same GTX 1060 video card but mine is a desktop. Have you converted over to endeavouros repos? I think i would be using the nvidia-dkms drivers since you have both kernels installed.

The Nvidia-dkms driver is installed .
The system booted without problems on 5.14 until approx. 2 days ago.
Even if this is an antergos install I am not using the antergos repos but pure arch repos.

It doesn’t show me that dkms is installed. I see you are on Arch converted then from Antergos. So arch repos. I guess you could reinstall the dkms drivers and see.

sudo pacman -S linux-headers linux-lts-headers

then

sudo pacman -S nvidia-dkms

1 Like

and rebuild kernel images:

sudo mkinitcpio -P

2 Likes

Update:
The lastest updates of today have solved the problem, the sytem boots again into the desktip with kernel 5.2.14.
J.

3 Likes

Update:
The problem is back with Kernel 5.3
J.

I think it’s because you do not have nvidia-dkms installed but only the nvidia. Because you are running the lts kernel you will get this issue everytime a new kernel is updated. That is why you need the dkms version.

sudo pacman -S linux-headers linux-lts-headers

sudo pacman -S nvidia-dkms

sudo mkinitcpio -P

Nvidia-dkms was and is installed.


Any other ideas?

Did you rebuild it as Joe wrote, I had to do that to make it work again.

I previously rebuilt , but I had to rerebuild to fix it.
Everything seems to be back to normal now.
Thanks for all suggestions.
J.

Update: The system doesn’t boot anymore graphically with Kernel 5.3, without any updates.
Aren’t there any logs that could help me to find out what strange things are going on here?
J.

That’s strange as i have the same video card and and Intel cpu with onboard HD 630 Graphics. I have the graphics set to use only the Nvidia card in the UEFI Bios. What desktop are you running? It could have something to do with the desktop manager/greeter?

Maybe look at the xorg log.It’s in /var/log/Xorg.0.log Also the log for you desktop manager. Mine is lightdm so it’s in it’s own folder in var log.

Check the greeter settings in lightdm?

I had the same problem when updating to Kernel 5.3. My symptom is that Nvidia still works, it just takes 90 seconds to go from the black screen with flashing cursor to gdm appearing. Have you tried letting it set for a couple of minutes to see if it eventually comes up?

https://forum.endeavouros.com/t/linux-kernel-5-3-is-officially-released/1558/8

Since I am not a gamer, I reverted back to nouveau and it works fine. Then just wait until the problem gets worked out.

Pudge

Further troubleshooting and a fix for this problem

Possible fix for your problem

So, some more infos: I am using Plasma5 as DE with sddm set to autologin.
I don’t get the 90 seconds delay, the black screen with flashing cursor shows “forever”. Forever in this case means, that I waited for 5+ minutes.
I am not sure if I want to try wayland and nouveau, I fear this will limit my gpus performance massively.
J.