Linux kernel 5.3 is officially released

I tried this again this morning, turns out nvidia-dkms is working, kind of.

From the time the black screen and flashing cursor appears, and getting the gdm screen is 90 seconds. Tried it twice, 90 seconds. I was definitely not waiting 90 seconds last night, not in the mood I was in when it appeared to not work at all. :angry:

I need to think about this for a while before proceeding.
I downgraded to kernel 5.4.14 and it still takes 90 seconds to get the gdm screen.
Since no one else is having problems, I’m thinking it might be hardware related.
Next step, since it is my test compter, re-install and see what happens.

What desktop are you on Gnome? Ya 90 seconds would be way to long for me too. 10 maybe? I don’t have that issue on Cinnamon with Nvidia or Nvidia-Dkms. My other computers have older HD Radeon cards also no issues.

Before I used to run Linux Mint like a rolling release. I would update kernels everytime one came out …every two weeks. I would go to Linux kernels and download them and use the g-debi installer. Never ever had any issues unless a Cinnamon update borked the desktop but never kernel updates.

I know you are a way more advanced user than am I; however, I seem to recall seeing some similar topics on the forum recently regarding system entropy affecting boot times. The solution was whether ‘haveged’ is started/enabled. Perhaps I’m off-base (I probably am), but I thought I’d suggest it to your consideration.

First off, all suggestions are valid and taken under consideration. So, I checked it
It seems to be OK. Check under Security on the screenshot.

@ricklinux Yes, it is Gnome. After complete new install, which of course included Kernel 5.3 and Gnome 3.34, still have the same problem. Nvidia works, but has 90 second delay. Went back to nouveau and all is well. I am not a gamer, so nouveau works perfectly fine for me, and I am using FOSS instead of proprietary drivers. :innocent:

Since I am the only one having this issue, I will do as I have done with Arch for well over a decade. I will wait a few weeks, try it again and it will probably work.


1 Like

Did you try another desktop manager like lightdm on Gnome?

Is it nvidia on wayland ?

Is this on bare metal i assume? I’m just having difficulty understanding why? Do you get the same if using Cinnamon?

@ricklinux Did you try another desktop manager like lightdm on Gnome?

Just GDM.

@ringo Is it nvidia on wayland ?

It says it is on wayland with nouveau, so I assume it’s wayland with Nvidia

@ricklinux Is this on bare metal i assume? I’m just having difficulty understanding why? Do you get the same if using Cinnamon?

Yup, on bare metal, uefi, AMD RYZEN 7 2700 and B450 based motherboard. Haven’t had time lately, so I haven’t tried it with Cinnamon. Next week is going to be even crazier, so it’s probably on the shelf for at least a week. I might get time tomorrow?


That’s the culprite, I think, try Xorg instead. Wayland and Nvidia is still not a match made in heaven.


Since the 90 second delay is After the black screen with flashing cursor, and Before the GDM screen where one would normally choose xorg or wayland, I did not think this would be a solution. Now I have to go to that recipe thread and find a good recipe for preparing Crow to be eaten.

To fix this, I edited the /etc/gdm/custom.conf file and un-commented:
# WaylandEnable = false
WaylandEnable = false

I was then able to toggle the 90 second delay on and off by enabling/un-enabling this option.
So during the boot up process, it must be checking this option in this file long before it actually gets to the GDM screen. I would not have thought of this, Thanks @ringo and @Bryanpwo !

Great, now I have to decide if I want xorg and Nvidia OR nouveau and wayland.

@ricklinux From what I could get from the Arch Linux Wiki, I don’t think Cinnamon uses Wayland. So, I don’t think Cinnamon would have this problem.


1 Like

So are you are saying is that it enables Wayland when it uses Nouveau? I’m going to check my Nvidia install on Uefi using DKMS on Cinnamon. It almost makes me want to install Gnome just to see? :thinking:

Gnome starts up with Wayland by default, nowadays you have to choose Xorg manually the first time with Gnome.

I haven’t installed Gnome on my newer system with the Nvidia card and Uefi. Where does it come up to choose between xorg and wayland?

@Pudge Is this related to both problems. The slow startup and the black screen?

Normally, at the GDM login screen there is a Gear (settings) that you click on to choose xorg or wayland. My 90 second delay was occurring Before the GDM screen appeared.

As @Bryanpwo said, wIth Gnome wayland is default. In this case I edited the /etc/gdm/custom.conf file to over ride that default.

With Wayland enabled (default):
Nouveau works fine (remember, nouveau & Nvidia drivers are in conflict and cannot co-exist)
Nvidia has a problem,

WIth Wayland disabled and xorg enabled (by editing the file)
Nvidia does not have a problem

Nouveau will not work with xorg only and wayland disabled.  I actually tried it.

So, in my case, with my hardware, and EOS with Gnome, you can have only two setups that work which are mutually exclusive
Nvidia drivers and xorg
nouveau drivers and wayland.
Any other combinations will have problems.

Yes, one problem with two symptoms, first black screen then 90 sec delay before GDM screen.


This is good to know in case i try Gnome on my system with Nvidia. I was contemplating picking up a Ryzen 5 2600X and upgrading. I am trying to decide on a video card as i also could go newer and get the Ryzen 5 3400G with graphics or go Nvidia or Amd video card with the 2600X.

yeah these days wayland can work with nvidia, but thats also some prize because not full support since nvidia opend up some documentation mayby in future would be better :slight_smile: there is some GL compatible layer to make wayland work with nvidia but makes otherside a pain like booting probably…

If you have a Nvidia card and you boot up the first time with Nouveau, you can also choose Xorg session in GDM, then login and enable the Nvidia driver, boot up again and the system will always remember Xorg as default, also after a major update.

You should be able to achieve the same effect by editing /etc/gdm/custom.conf to say WaylandEnable=false