System Update Failure

not sure if this is right place for this…installed EOS yesterday with no problems, but when attempting
System update I get the following errors…it looks like the 2 flagged pkgs installed, but still give errors

:: Retrieving packages...
 exfatprogs-1.1.3-1-x86_64                                                              39.6 KiB   160 KiB/s 00:00 [--------------------------------------------------------------------] 100%
 pcsclite-1.9.4-1-x86_64                                                                99.3 KiB   209 KiB/s 00:00 [--------------------------------------------------------------------] 100%
 Total (2/2)                                                                           138.9 KiB   239 KiB/s 00:01 [--------------------------------------------------------------------] 100%
(298/298) checking keys in keyring                                                                                 [--------------------------------------------------------------------] 100%
(298/298) checking package integrity                                                                               [--------------------------------------------------------------------] 100%
error: exfatprogs: signature from "Frederik Schwan <>" is unknown trust
:: File /var/cache/pacman/pkg/exfatprogs-1.1.3-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: pcsclite: signature from "Frederik Schwan <>" is unknown trust
:: File /var/cache/pacman/pkg/pcsclite-1.9.4-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

AUR update check:
:: Searching AUR for updates...
 there is nothing to do~~~

machine info:

  Host: THOTH-OPTOPLEX-9020 Kernel: 5.13.12-arch1-1 x86_64 bits: 64 
  Desktop: Xfce 4.16.0 Distro: EndeavourOS 
  Type: Desktop System: Dell product: OptiPlex 9020 v: 00 
  serial: <superuser required> 
  Mobo: Dell model: 00V62H v: A01 serial: <superuser required> BIOS: Dell 
  v: A15 date: 11/08/2015 
  Info: Quad Core model: Intel Core i5-4570 bits: 64 type: MCP cache: 
  L2: 6 MiB 
  Speed: 2252 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 2252 2: 2195 
  3: 1810 4: 3193 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  driver: i915 v: kernel 
  Display: x11 server: 1.20.13 driver: loaded: intel 
  unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  driver: snd_hda_intel 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  driver: snd_hda_intel 
  Sound Server-1: ALSA v: k5.13.12-arch1-1 running: yes 
  Sound Server-2: PulseAudio v: 15.0 running: yes 
  Device-1: Intel Ethernet I217-LM driver: e1000e 
  IF: eno1 state: down mac: 18:66:da:02:79:c1 
  Device-2: Edimax EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS] 
  type: USB driver: rtl8192cu 
  IF: wlan0 state: up mac: 80:1f:02:b6:d2:ce 
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci 
  Local Storage: total: 476.94 GiB used: 5.74 GiB (1.2%) 
  ID-1: /dev/sda model: 30TT253X2-512GB size: 476.94 GiB 
  ID-1: / size: 229.33 GiB used: 5.74 GiB (2.5%) fs: ext4 dev: /dev/sda3 
  Alert: No swap data was found. 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 183 Uptime: 10m Memory: 15.54 GiB used: 1.28 GiB (8.2%) 
  Shell: Bash inxi: 3.3.05~~~

Try this:


The pacman data base is corrupted. Update your mirrors and try again.

1 Like

fixed it…thanks !!! :star_struck:

sudo pacman -Sy archlinux-keyring fixed it…


That will do it! :+1:


You should have marked post #2 as the solution as you were given the information which to look at to resolve your issue.


yes, offline installs need to update archlinux-keyring before doing the first full system update.

1 Like

true…but I’m still a noob here & learning as I go…and I’m a senior citizen… :astonished:

Just trying to guide you along the way … You won’t be a noob for long. :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.